brackets for if/else don't start automatically

I like to always use brackets, no matter if it's one line or many in the condition's execution.  I think I set the Settings correct to specify this.

But when I type if, and am done with the condition, I use Control-Enter to jump to the next line, and it indents, but it never adds the brackets!  Is there another key sequence to start the block?  (if I just hit Enter, it puts the ) from the end of the condition area on the next line)

2 comments
Comment actions Permalink

Hi there,

If your settings are correct, then try Ctrl+Shift+Enter instead -- works for me.

0
Comment actions Permalink

I am on Mac, but got it to work with Shift Command enter.  (I think I tried just about every other combination of shift, control, and alt! :) )  I also looked on the keyboard sheet, but maybe I missed it, if it was there.

Thank you again sir!

And as a side note, I feel like I am still dreaming, PHP Storm rocks so hard!  Pretty much perfection as far as syncing my dev server, allowing easy source control, the separate local source control for backtracking edits between commits, the overall splendor of the editor's features, etc.  And still running fast on a four year old Macbook Pro after being up three days!

0

Please sign in to leave a comment.