On save new line added to end of file. How stop this?

I did a search in the forum for this but did not get any results back.  I looked in settings but there are so many I am not sure where to look.

When I save a file, PhpStorm adds a new line to the end of the file.  How do I stop this from happening?

Thanks.

14 comments
Comment actions Permalink

In PHP Storm 2018.2.5 

File | Settings | Editor | General --> Other ---> Ensure line feed at file end on Save 

14
Comment actions Permalink

Hi there,

Some tip first: If you do not know if some configuration option is available and where it located in Settings window, then use Search box in Settings window (the very first thing on left top corner) -- extremely helpful feature in such situations. If found nothing -- try to use another spelling/naming (sometimes the option can be named differently to what particular person may expect).

Back to your issue -- untick the following option: File | Settings | Editor --> Ensure blank line before end of file on Save
Try searching for "blank line" on Settings screen and see how it works.

10
Comment actions Permalink

@Dragos Rosu

Works just fine here. Don't know other options that could do such thing (unless some another tool/plugin does it).

The only thing I can think of ... 1) do you have .editorconfig files in this project?.. and 2) Do you have EditorConfig Support plugin installed? Settings from such file will override similar option from IDE Settings/Preferences (the nature of such files).

8
Comment actions Permalink

Note that the Editorconfig plugin may override this setting if you .editorconfig file has:

insert_final_newline = true
7
Comment actions Permalink

You either enable it or disable it, it still adds that line on Windows 7 / Windows 10 and Ubuntu 14 machines. Why is that??

2
Comment actions Permalink

That was it, thank you kindly @Andriy Bazanov!

I was hating Webstorm for a while now for this "hidden bug". Someone commited some editor configuration in our repository and that broke it up.

 

Thank you kindly!

2
Comment actions Permalink

https://intellij-support.jetbrains.com/hc/en-us/community/posts/207071445/comments/207471069

 

FYI i tried finding this with the search bar in preferences and couldn't find it, that's why I came here. I searched newline, \n, and end of file. I didn't think about searching 'trailing space' or 'blank space'. Might be nice to be able to find it with 'newline' or 'end of file' as search params. would have saved me the search. Thanks for helping me find it though!

1
Comment actions Permalink

Let me add that if there is already a blank line at the end of the file it does not keep adding new lines.  If there is NO blank line then when I save the file a new blank line is added.  I actually want some files to have no blank line at the end.

Thanks.

0
Comment actions Permalink

There is an entire section about new lines in php, this one is missing. 

The setting is unsearchable. In general phpstorm settings are hard to work with..

0
Comment actions Permalink

i tried the same thing, the only thing that really work was edit the .editorconfig file changing the key insert_final_newline to false 

0
Comment actions Permalink

@Mcriverag

the only thing that really work was edit the .editorconfig file changing the key insert_final_newline to false 

So you had it set to TRUE before? In such case it's expected behaviour: settings from .editorconfig file will take over the IDE own settings (the whole nature of such file).

So you either:

  • edit your .editorconfig file as per your needs (the best option as this will work in another IDE/editor as well + settings are part of the project files so another person will have easier time configuring his editor)
  • remove .editorconfig file so only IDE settings are in action
  • disable EditorConfig support in the IDE

 

0
Comment actions Permalink

They messed with this again and it is still not searchable (not even if you search for the exact text).

0
Comment actions Permalink

Ba Grootjen, the settings entries' names are not indexed as they are but rather by keywords, a query like "save file line break" finds the settings item.

0
Comment actions Permalink

If you want your files to be actual files according to POSIX standards, they need a line ending at the end of the file.

https://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap03.html#tag_03_206

3.206 Line

A sequence of zero or more non- <newline> characters plus a terminating <newline> character.

Note, however, that a single newline at the end of the file makes Storm make it look like there is a blank line at the end of the file. Use a hex editor to confirm that there is only a single newline at the end of the file. Maybe a better solution would be a gutter icon or a visual endOfFileNewLine character

0

Please sign in to leave a comment.