ZendDebug installed, seems to work, browsers pops up, but no breakpoints get hit.

ZendDebug installed, seems to work, browsers pops up, but no breakpoints get hit.

When I hit the debug button i get my browser window with the page i'm debugging but no breakpoints get hit in the phpstorm. i have this URI

http://mymoneris.local:8888/?send_sess_end=1&start_debug=1&debug_port=10137&debug_session_id=16689&debug_stop=1&debug_host=10.10.10.115%2C127.0.0.1&debug_start_session=1

I'm using latest webstorm, php5.3 MAMP, with zend debug from zend.

Anyone else have this problem/know what I can do about it or if I'm doing something wrong in the setup?

14 comments
Comment actions Permalink

Hello Victor,

Please describe your server configuration(under 'PHP -> Servers') - screenshot would be veru useful.

Do you use path mappings?

Thank your for feedback!

0
Comment actions Permalink

I didn't have the pathmapping check mark enabled. And now that I enabled it, the breakpoints tell me the paths are not set. How/where do you set these paths?

I attached a screenshot of the setup.



Attachment(s):
Screen shot 2011-03-01 at 11.47.10 AM.png
0
Comment actions Permalink

Victor,

Does physical paths of files on server differ from physical paths of files in project? If true, you should enable 'use path mappings' checkbox and set mappings between roots.
The most popular scenario is 'Project root -> Document Root'.

This blogpost could be useful for you - http://blogs.jetbrains.com/webide/2011/02/zero-configuration-debugging-with-xdebug-and-phpstorm-2-0/

0
Comment actions Permalink

Hi, can you please clarify in what case the phisical paths on the server would be different then the paths in the file project? My development server is on my local machine and my project is the same project that is server through the server.

The blog post is not really related to Zend debug at all, and offers quite a different solution.

0
Comment actions Permalink

Victor,

Hi, can you please clarify in what case the phisical paths on the server would be different then the paths in the file project?

E.g. you have site deployed on remote server and you open local copy of its sources in project.

My development server is on my local machine and my project is the same project that is server through the server.

Do you use symlinks?

Thank you for feedback!

0
Comment actions Permalink

I'm having the same problem.  I've been using zend debugger since the beta on phpstorm 2 and I'm pretty sure it broke with this last patch.  Debugger works because the "Variables" pane shows "Connected" when I click refresh on my browser.  But no breakpoints are hit.

If I change the debug config to "break at first line," then it will break on the first line.  However, if I then click resume, it will not stop at a breakpoint further down in code.

I am using basic zend server ce install with project directory right in htdocs. No fancy paths.  Plus, it worked fine a week ago.

i'm running on os/x using the php 5.3 version of zend server.

0
Comment actions Permalink

Hi, No no symlinks, its a pretty simple setup.

0
Comment actions Permalink

Hello Henry,

I'm pretty sure it broke with this last patch.

Do you mean 103.156?

Thank you for feedback!

0
Comment actions Permalink

Victor,

No no symlinks, its a pretty simple setup.

Ok, disable 'Use path mappings'.
Please ensure that you have installed Zend Debugger correctly - http://confluence.jetbrains.net/display/WI/Zend+Debugger+installation+guide

Thank you for feedback!

0
Comment actions Permalink

No, I am on 103.99   since 2.0 was released I have just been using the production version and 103.156 is eap.  I am happy to use the .156 if you think it will fix the problem.

In the mean time attached is debug log and a screenshot showing the breakpoint set.  Steps used to produce problem and log...

1) enable debug as per kb
2) launch phpstorm
3) clicked the debug button to start debugger
4) set a breakpoint on the second line of code
5) load php page in browser - no stop at break
6) close phpstorm



Attachment(s):
idea.log.zip
Screen shot 2011-03-03 at 4.55.19 PM.png
0
Comment actions Permalink

Victor,

Do you still have an issue?

0
Comment actions Permalink

Henry,

I reproduced the problem. Thanks for report! We will try to fix the issue until the next EAP.
Workaround - use "Listen PHP Debug Connections" button for debug. Related info - http://confluence.jetbrains.net/display/WI/Zero-Configuration+debugging+with+PhpStorm+2.0

0
Comment actions Permalink

Cool, thanks for the work-around. I tried "Listen PHP Debug Connections" and it worked fine.

Henry

0

Please sign in to leave a comment.