PHPStorm2 open directory freezes

I have upgraded to PHPStorm2 and now when I go to open a directory it just freezes saying loading and i have to restart the application. Anyone else having this problem? I imported my settings from the older version is that an issue?

6 comments
Comment actions Permalink

What platform are you on?  Do you have any mapped network drives?  Any external drives that might be hanging up the overall directory list?  Any fancy 'FTP site as a drive letter' apps?

0
Comment actions Permalink

http://devnet.jetbrains.net/docs/DOC-260
or
http://devnet.jetbrains.net/docs/DOC-192

And please answer to questions about any "remote" content.

Also: Do you use symlinks?

0
Comment actions Permalink

I don't have any remote directories or external drives. I am on OSX leopard and no symlinks. I tried doing what those links you provided said to do for the stack trace and none of them worked. The little app didn't work and the idea.sh kept saying I don't have any JDK available but I do.

This is getting really frustrating, I can't open other projects.

0
Comment actions Permalink

Hi Dan,

I have the same issue as I reported here:

http://youtrack.jetbrains.net/issue/IDEA-65385?query=by:+me

and it is marked as fixed in a future build. I'll have to try it when that build is released. In the mean time, in my ~/.bash_profile I added this:

alias pstormopen='open -a "PhpStorm 2.0.app"'

In terminal you can then just do

pstormopen /path/to/project

or cd into a folder first and do

pstormopen .

Michael

0
Comment actions Permalink

Thanks man, I guess that will have to do, will you message me if you ever see that they haved fixed it or you find another solution? I will do the same for you :)

0
Comment actions Permalink

No problem and will do.

0

Please sign in to leave a comment.