What version of the Zend Debugger is required?

With PHPStorm 2.0 I am trying to get Zend Debugging working on external Linux server (from a Windows box).  The page freezes, and in the notificications window the error I get is:

Cannot accept external Zend Debugger connection, Unsupported protocol version.

It's Zend Debugger v5.2.12.

This Zend Debugger works fine in Zend 5.5, 7.0 and 8.0 (people use different IDE's here, although I think we would all move to PHPStorm if we can debug through Zend Debugger).  Here is what phpinfo tells me about it:

Zend Debugger

Passive Mode Timeout 20 seconds
Connector PID 20685

Directive Local Value Master Value
zend_debugger.allow_hosts 10.1.0.0/16, 127.0.0.1 10.1.0.0/16, 127.0.0.1
zend_debugger.allow_tunnel no value no value
zend_debugger.connect_password no value no value
zend_debugger.deny_hosts no value no value
zend_debugger.expose_remotely always always
zend_debugger.httpd_uid -1 -1
zend_debugger.max_msg_size 2097152 2097152
zend_debugger.tunnel_max_port 65535 65535
zend_debugger.tunnel_min_port 1024 1024


Any thoughts on how I can get this working, I would really like to leave Zend Studio behind for debugging...

4 comments
Comment actions Permalink

Hi Kris.

Please collect debug log as described there: http://devnet.jetbrains.net/docs/DOC-1202 and attach to your post. It will help phpstorm developers to identify your problem.

0
Comment actions Permalink

Attached is the log file after turning on debugging for com.jetbrains.php.debug.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Hello Kris,

At the moment the minimal supported version of Zend Debugger is 5.2.14(2006040705 protocol version). Please upgrade your Zend Debugger. You can download the latest binaries from zend.com - http://www.zend.com/en/download/151.

Thank your for feedback!

0
Comment actions Permalink

Upgraded to 5.2.14 and everything works perfectly.  

Just have to say, PHPStorm 2.0 is amazing!  Finally I can get away from the painful Zend Studio products!

0

Please sign in to leave a comment.