"xdebug is not installed" & "debugging is disabled" errors. Why?

I am using PHP5.3 on Windows 7 64bit. I placed the xdebug dll in the php folder, added the xdebug section below in php.ini and configured the debug settings. When I start the debugger, I get an error window with "xdebug is not installed" & "debugging is disabled" errors and a "Debug connection established" established message and the web page displays fine. However no breakpoints are hit.
I displayed the output of phpinfo() and nothing about xdebug was showing.
The help mentions locate the xdebug section. I didn't have one. Was it supposed to be there? Does Zend need to be installed?

Why does it say xdebug is not installed? Did I miss a step?

[XDebug]
zend_extension="D:\Program Files (x86)\PHP\php_xdebug-2.1.0-5.3-vc6-nts.dll"
xdebug.remote_enable=true
xdebug.remote_port=9000
xdebug.profiler_enable=1
xdebug.profiler_output_dir=t:\temp

18 comments

Hello abdu,

Yes, it seems that PhpStorm is correctly saying that Xdebug is not installed - it's confirmed by phpinfo() output. First, please check that you have the right Xdebug build. Then ensure that no conflicting extensions are installed (e.g. Zend optimizer may prevent Xdebug from working properly).

Regards,
Kirill

PS If nothing helps, please attach your php.ini file so we can try to check ourselves.

0

Iam running PHP 5.3. This is my php.ini.



Attachment(s):
php.ini.zip
0

Hi,

Your php.ini looks quite OK from the first glance (well, we are not PHP gurus here, rather Java ones :)) .

Try disabling extensions that you have - may be one of them is the reason.

Regards,
Kirill

0

The checker suggested moving the dll to another folder and that did the trick!
That checker is a great tool. I love tools which are easy to use and pinpoint the problem.

0

Hello,

I have the same problem

Do you find a solution

0

Hello houpdelta houpdelta,

Please try checker and ensure that your have xdebug installed.

Thank you for feedback!

0

Thank for the answer, but the link "checker" is broken

0

I have doing this test, and the answer is
checker.png
so xdebug is good.
But phpstorm says "xdebug is not installed" X-(

0

Could this be caused by a software firewall bocking xdebug from connecting to PhpStorm on port 9000?

Or would that result in a different set of error messages?

0

houpdelta houpdelta,

Do you a problem with the messages only? Try to disable "Validate XDebug before debug" option and initiate debug session.

0

Hi,

The good solution is "disable xvalidate debug".
I have now the message in the console.

Now, it's not easy to configure "run/debug configuration".
I have a uwamp server on local.
I have a virtual host on uwamp:
<VirtualHost *:80>
#UWAMP Generate Virtual Host
    DocumentRoot "J:\Mes Projets\Mes Projets PhpStorm\yam\www\fr"
    ServerName "www.dev.fr.yam.home"
</VirtualHost>
And I now , I don't know get a good parameters ?
?:|

0

houpdelta houpdelta,

The good solution is "disable xvalidate debug".

It could be a bug in our validator. Does debugger work for you?

Now, it's not easy to configure "run/debug configuration".

I have a uwamp server on local.
I have a virtual host on uwamp:
<VirtualHost *:80>
#UWAMP Generate Virtual Host
    DocumentRoot "J:\Mes Projets\Mes Projets PhpStorm\yam\www\fr"
    ServerName "www.dev.fr.yam.home"
</VirtualHost>
And I now , I don't know get a good parameters ?

Document root is a mounted folder or you open your files on server directly in PhpStorm?

0

Hello houpdelta houpdelta,

Do you still have an issue with setting up xdebug?

0

Hello Michael,

Sorry for delay. Do you still have any issues with setting up xdebug?

Thank you for feedback!

0

Thanks for following up - I had no issues with xdebug, I was just taking a stab at  what the problem might possibly be.

0

Hello,

Yes, I still have this problem. I am a little discouraged with this problem.


Thank, for you request.



0

houpdelta,

Have you tried to debug in PhpStorm 2.0?
We disabled xdebug validation because of its unreliability. We will give back validation in the further versions but in different manner.

0

Please sign in to leave a comment.