Возможно ли определить DOCTYPE для всего проекта при использовании движка на базе Zend/Smarty

Добрый день
Я верстаю проекты написанный на базе Zend/Smarty и мне нужно использовать HTML5, но PHPstorm не понимает какой доктайп у шаблонов и не делает автокомплит тегов. Можно ли назначить доктайп для всего проекта и если да то как?

Заранее спасибо.

4 comments
Comment actions Permalink

Try this:

File | Settings | Resources -> Default HTML Language level: HTML 5

0
Comment actions Permalink

попробовал, но ничего не изменилось, там при создании нужно указывать путь к ресурсу может из-за этого не работает...

указал путь к доктайпу html5 который есть в системе, но тоже не сработало

0
Comment actions Permalink

screen_05_1.png
You may need to re-open templates after this change.

Also, if you have DOCTYPE defined in your template, it will take over the default one (which is defined in the project settings -- path described above).

0
Comment actions Permalink

Спасибо за помощь, я просто работал на релизе 1.02 и никак не мог найти то о чем вы говорили.
Еще раз спасибо и прошу прощения за то что потратил ваше время.

0

Please sign in to leave a comment.