PS-102.104 to 102.206 upgrade, Debugger stopped stopping. what changed?

os: kubuntu 10.04
PhpStorm 2.0Beta
build PS-102.206

I used to click the listen button on phpstorm then hit refresh in the browser and the debugger would stop.

I upgraded this morning and now the debugger is not stopping.  Are there some new settings that need to be set?

Cheers


--edit--
doesnt matter, gone back to 102.114.  102.206 seams to have more bugs, not less.

14 comments
Comment actions Permalink

Hello michael,

I upgraded this morning and now the debugger is not stopping.  Are there some new settings that need to be set?

Please elaborate. What are you talking about - stopping of session or stopping of connection?

0
Comment actions Permalink

It stopped stopping on breakpoints.

I had a break point set in an included class file which did not get stopped on.

Even after I went back to 102.114 the break point did not stop.  Not sure if this is anymore, or something with the upgrade downgrade.

I got it working by adding a path to the project from the "edit path mappings" dialog.  Once i set the main path of the folder on the local machine to the root directory of the project, then the debugging breakpoints started working again.

Thanks for the help Nikolay.

0
Comment actions Permalink

Hello michael,

Do you still have any troubles with debugger in EAP build 103.8?

0
Comment actions Permalink

Yeah still issues.  102.114 was easier to set the debugger up.

I have got it going, but it did take some fiddling.

In 102.114  i just clicked the "listen" icon and then if i refreshed the web-page while listen was green the break points would work.

now in 103.8 i can make the debugger stop, by first setting up a debugging profile for the file i want to debug, then click the debug icon to make the IDE wait for incoming connections (thought this was the purpose of the listen button.) then turn on the listen button and refresh the web-page.

The first thing that will happen is the debugger will complain that  "Remote file path 'path/to/the/file/on/the/server.php' is not mapped to any file path in project" with "Edit path mappings" underneath it.

Once i have set the project files to map to the "Path on server" then debugging will stop for this file.

Seams like if i want to debug a file, i first have to start the debugger waiting for that file.  I liked it better before, when I was asked "there is an incoming connection, which file does this mapp to" and all files could be debugged without making a debugging profile for them.

-- edit --

I just noticed something.  I had the "listen" button still on in the IDE and opened PhpMyadmin that is on the same server.  The debuger asked me if i wanted to start debugging or ignore the connection.  This is weird, because it doesnt ask me for the actual project i DO want to debug.  It feels like since the debugger has run before for this project that the ide doesn't feel like it should ask me if i want to "debug" or "ignore connection" but rather goes straight into debug mode, but doesnt know what to do.  so the break points are not stopped at.

I looked for any left over debugging info to try to get the "Debug" or "Ignore" dailog to popup again, but cant.  for the site that has been debugged in the past, i cant make the popup popup again.  (but for phpmyadmin it will ask me several times for a single page refresh if i keep hitting "ignore connection.")

How do I clear out old connections so i can get asked again.

0
Comment actions Permalink

michael,

102.114 was easier to set the debugger up.

Debugging workflow/settings haven't changed since 102.114. Please check you mappings settings.

I just noticed something.  I had the "listen" button still on in the IDE and opened PhpMyadmin that is on the same server.  The debuger asked me if i wanted to start debugging or ignore the connection.  This is weird, because it doesnt ask me for the actual project i DO want to debug.  It feels like since the debugger has run before for this project that the ide doesn't feel like it should ask me if i want to "debug" or "ignore connection" but rather goes straight into debug mode, but doesnt know what to do.  so the break points are not stopped at.

I looked for any left over debugging info to try to get the "Debug" or "Ignore" dailog to popup again, but cant.  for the site that has been debugged in the past, i cant make the popup popup again.  (but for phpmyadmin it will ask me several times for a single page refresh if i keep hitting "ignore connection.")

This dialog appears if PhpStorm get connection from unknown host and intended for initial configuration. After you press 'Debug' button the settings will be stored in Project Settings -> PHP -> Servers. Delete server and you will get this dialog again.

Thank you for feedback!

0
Comment actions Permalink

Perfect!  Thanks Nikolay.  I deleted the server and i was asked if i wanted to "Debug" or "Ignore connection".  I selected "Debug" and it worked exactly as expected. It stopped on all the break points without having to map any paths.

:)

0
Comment actions Permalink

Hi michael,

Just want to add small note to Nikolay's message: There has been some changes in configuration file regarding PHP debug mappings (the part with which local folder matches remote folder) -- these settings are now saved under different path/parameter name, therefore if you have used mappings they need to be redone (I've faced this myself and was very confused when debugging work just 2 minutes ago in 102.114 build and in 103.8 it stopped despite the fact that I'm using exactly the same routine).

@Nikolay
It would be great, if PhpStorm can warn me in such situations: when I have "use mappings" ticked but no actual mapping is setup (because I have not done it yet for new config .. or because they were lost/reset due to the changes to PhpStorm config structure etc)

0
Comment actions Permalink

Andriy,

Just want to add small note to Nikolay's message: There has been some changes in configuration file regarding PHP debug mappings (the part with which local folder matches remote folder) -- these settings are now saved under different path/parameter name, therefore if you have used mappings they need to be redone (I've faced this myself and was very confused when debugging work just 2 minutes ago in 102.114 build and in 103.8 it stopped despite the fact that I'm using exactly the same routine).

Right, this changes appeared in 102.206.

It would be great, if PhpStorm can warn me in such situations: when I have "use mappings" ticked but no actual mapping is setup (because I have not done it yet for new config .. or because they were lost/reset due to the changes to PhpStorm config structure etc)

Sorry for that, usually we try to provide any auto migration(but it can be impossible in some cases).

0
Comment actions Permalink

Thanks Andriy :)

0
Comment actions Permalink

Nikolay,

I understand that this is the nature of EAP build to have changes (even breaking changes).

My last paragraph was kind of feature request:

It would be great, if PhpStorm can warn me when I have "use mappings" ticked but no actual mapping is setup
0
Comment actions Permalink

Andriy,

Sorry for misunderstanding.
Sounds reasonable. Please report a feature request:)

0
Comment actions Permalink

Andriy,

BTW, have you ever try our new "Skipped paths" feature?

0
Comment actions Permalink
Sounds reasonable. Please report a feature request:)

Will do.

BTW, have you ever try our new "Skipped paths" feature?

So far I had no need in such feature. And if I'm debugging some code that is called in almost every page (bootstrap file or some other file/code block that is shared or does common initializations etc) I would test in regardless of where this request is came from (page view .. or css/js generation/merge etc) to ensure that all (well, most) possible scenarios are covered/working. But I do see that under some circumstances (where I may need to debug only specific part of such code that can only be executed if specific urls/path is used) it can be very handy to have such feature, and it is good that PhpStorm already has it.

This feature is more suitable for sites where each script/file does one (or few related) task -- like WordPress for example. From what I understand (how this feature works) it may not be that useful for projects with single entry point (MVC where one script (index.php) handles all incoming requests). But I can be wrong on how it works and how it can be used -- I hope to see some article/tutorial/blog post that covers this feature usage with examples at some point in the future.



Right now (at this moment) I'm missing "Script output" tab ... (I know it is scheduled for 2.1).

0
Comment actions Permalink

Andriy,

Thanks for detailed answer and for the reported issue!:)

This feature is more suitable for sites where each script/file does one (or few related) task -- like WordPress for example. From what I understand (how this feature works) it may not be that useful for projects with single entry point (MVC where one script (index.php) handles all incoming requests)

The basic use case - ignoring of ajax requests(and vice versa - ignoring the main scripta and debugging only ajax request). We haven't got any meaningfull feedback about this feature yet.

But I can be wrong on how it works and how it can be used -- I hope to see some article/tutorial/blog post that covers this feature usage with examples at some point in the future.

We have plans to cover with tutorials/blog post all new debugging features. So stay tuned:)

Right now (at this moment) I'm missing "Script output" tab ... (I know it is scheduled for 2.1).

Why do you need to have see output in IDE if you can see it in browser?

0

Please sign in to leave a comment.