WebStorm indenting on wrap

Hi,
Just checking out WebStorm and I have a very basic question. I'm editing an html document with some embedded javascript and when I'm in the script section of the document and I hit return the cursor jumps to the next tab stop. I was of course expecting it to jump in line with the previous statement until I indent using my tab keys. I've looked through the preferences and can't seem to see where to change this setting. Thanx

(here's a little screen shot https://skitch.com/philosopherdog/rewnu/beginning-js-users-dogdutyascetic-desktop-beginning-js-test2.html-jetbrains-webstorm-1.0.2 )

4 comments
Comment actions Permalink

Hi Steve,

There are some issues reported on Bug & Issue Tracker regarding proper indentation/positioning of the cursor (happening under some circumstances) -- even in EAP build (v2 beta). For example: WI-4134.

As for the settings, have a look at File | Settings | Code Style, especially General -> Tabs and Indents.

0
Comment actions Permalink

I fiddled with it, and now I have a different problem. It seems to want to wrap all the way back to the beginning of the line and wants me to tab over to where I was. Ahhh. Am I doing something wrong? Am I missing some setting somewhere? I'm expecting this to smart tab, that is, to remember where I am in the indentation and allow me to tab forward what I need to.

0
Comment actions Permalink

If you think you have messed up in "File | Settings | Code Style" -- just switch back to Default scheme.

There is one more option available which affects indenting (could not find it first time so I thought it was a setting in another IDE): Settings | Editor | Smart Keys --> Enter | Smart indent.

0
Comment actions Permalink

Greetings Andriy,

I think I finally got it working properly. Many thanks. I have another issue now, but this is unrelated to this thread about popups for variables in use. I'll put the question into a separate thread. Thanx again!
0

Please sign in to leave a comment.