PhpStorm 2 - Not include the Form in autocompletion

Hello,

I'm test it.
I'm programing using the Zend Framework.

I want to know it's normal that when I wrote "Zend_Form_" it not automatically see "Zend_Form_Element_****" ?

Thanks

2 comments
Comment actions Permalink

Hi Paul,

1) Do you have Zend Framework folder included in your project (directly in Settings | Directories or indirectly via external libraries in Settings | PHP) ?
2) There more classes that starts with Zend_Form_ -- not just Zend_Form_Element_****, but Zend_Form_Decorator_**** as well. In autocomplete popup such entries usually would be listed before Zend_Form_Element_**** entries (when sorted alphabetically).
3) The completion popup -- do you invoke it manually (Ctrl+Space) or is it done automatically (Settings | Editor | Code Completion) ?

0
Comment actions Permalink

Hello,

Thanks.

I go to preferences, and in Directories add the link to Zend and now it works !

Thanks a lot :)

0

Please sign in to leave a comment.