Debug & Mapping

What about mapping with some root directories included in project.
I have magento directory – core magento sources and separate directory  with my sources. 2 directories deploying into one directory to server.  When I run debug (xdebug), appear error: Cannot find the local copy of  file…
Debug Error:

Comment actions Permalink

Hi Vitaliy,

Looks like devs did not thought about such scenario (where 2 different local folders can be mapped into one folder on remote server. What even more confusing for PhpStorm -- you have folders with the same names in both content roots).

For the moment you can solve the issue in 2 ways:
1) by copying content of Magento folder into project folder
2) using symbolic or hard links on your local computer. You can use Link Shell Extension (FREE).

The 1st one is more realistic (easier to do) -- you can always update Magento itself without overwriting your site's files (because of cascading file system they use). The 2nd option may sound better, but more difficult to implement (much more hassle) because you have folders with the same names in both Magento and Project folders.

If folder names would be unique then it could be done like this (using symbolic links):
1) install the above mentioned software (or use anything else that will do the same job)
2) remove Magento folder from the project
3) create symbolic link from Magento folder (not the folder itself, but subfolders -- app, js, lib etc). Based on info from screenshot you should have 7 links: 4 for folders and 3 for files.
4) launch PhpStorm and let it reindex new folders

Comment actions Permalink

I don't want to merge two folders, because it is very difficult to get my sources back from merged magento directory with saving directory structure. And I don't modify magento sources and use this directory for autocomplete and debug only. And I use ONE source folder of magento for all my projects (magento extensions).
Iit was working in previous version of phpstorm, but not now! :_|

Comment actions Permalink

If it was working before and now it does not (you should mention such facts straight away, in your first post), then you can report it as a bug to issue tracker:

What was the the previous version where it worked ?

Comment actions Permalink


Please report a bug request -

Thank you for feedback!


Please sign in to leave a comment.