98.521 XDebug MAJOR Problem...what the heck did you do????

Holy cow. I'm about to downgrade this sucker. I'm not sure what was changed, but upon moving to the new EAP this morning, I can't open a page once XDebug has been loaded via php.ini without it activating PHPStorm. This is NOT what I want. How do I turn that off?

Even if I did want it, the process does not work. It's trying to load /library/common.php and says they mapping is incorrect, but it isn't.

I'm probably going to have to downgrade this, but I mean come one, features like this need to be deployed with some warning.  Good grief.

13 comments
Comment actions Permalink

Filed a bug report.

http://youtrack.jetbrains.net/issue/WI-4320

It's completely unusable. I've downgraded.

0
Comment actions Permalink

Hi Keith,

They have changed a lot how debugging works (now it works similarly to debugging with Zend Debugger) -- see blog entry.

1) Xdebug listener is always ON (by default) -- you can change it in Settings | Debugger | PHP.

2) The same place if you want to disable "Break on first line", because similar setting from Debug Configuration is ignored (http://youtrack.jetbrains.net/issue/WI-4316?projectKey=WI).

3) Mappings ... yeah .. that is what I had to do for a Local deployment: http://youtrack.jetbrains.net/issue/WI-4291?projectKey=WI. Not a big of a deal once you have done it, but still ... quite frustrating on start.
Mappings are setup in Settings | PHP | Browser Toolbar Debug Mappings


P.S.
I must be lucky (compared to you) but after initial huge frustration/anger .. it works quite fine for me now (no new issues so far).

And since I'm using browser extension to controll debugger state (different approach to debugging workflow compared to what you most likely have) -- it's even easier (no need to turn xdebugger listener on/off all the time).

0
Comment actions Permalink

Hello Keith,

laurin1 wrote:

...features like this need to be deployed with some warning.  Good grief.

EVERY EAP publicates with blogpost. So you can learn about new features there.

About problems with XDebug - every EAP blogpost finishes with the following sentence:

Please note that ALL of this is work in progress and will undergo series of both technical and cosmetic changes.

f you have any issues you can report it to our bugtracker and I am very appreciate you for your report(WI-4320).

0
Comment actions Permalink

I understand all that, but and I read the blogpost, but I didn't understand what it meant by the changes. The changes made this morning cost me a lot of time (still are) and we are betting on this new version (the 1.0 version would not have motivated us to make the change to PHPStorm.)

0
Comment actions Permalink

I am not sure whether should I start a new discussion.

But I have read all posts about issues with denug in 98.521 version and didn't found how to solve problem of not working "Resume" button(key) while debugging.

Autostart is already off. Resume button is disabled. I press <F9>  output goes to debug console and browser continues to hang waiting for the end of request.

Is there any way to deal with this?

0
Comment actions Permalink

Hello Yuriy,

Unfortunately there isn't any workaround available. This issue is already fixed. Fix would be available in the forthcoming EAP.

Sorry for troubles.

0
Comment actions Permalink

thanks for the answer.

0
Comment actions Permalink

Yuriy,

Please try our new EAP(100.36).

0
Comment actions Permalink

Yes, it works.  thanks a lot!

The only one issue I am not sure what to turn off. Now it stops at the first line of index.php which is main controller for all requests.  "Break on the first line" is off.

0
Comment actions Permalink
"Break on the first line" is off.

Where/Which screen did you turned it off? Most likely in Run/Debug Configurations, which is only works if script was launched/requested from PhpStorm.

Have a look at the same option in Settings | PHP | Debugger instead -- it is for "external" debug requests.

0
Comment actions Permalink

Aha, indeed.

Thanks for the help.

0
Comment actions Permalink

I saw that and downloaded it. No problems so far. Will report them if find anything.

0

Please sign in to leave a comment.