High CPU usage (Linux 64Bit) and suggestion for 2.0

Playing with the 2.0 preview since some hours...

I'm not sure if its a bug.. Often there is a very hight CPU usage over minutes.
I have attached a memory snapshot...

Some suggestions:

  • I miss some default "Live Templates" for PHP (while, for, foreach, function, class,...) for a commercial PHP IDE this should be bundled
  • Same with some shipped default themes (darker themes etc.)
  • The settings page is very large (IMHO a bit too much options).. May be it would be better to have a basic and expert view, so the user will not be messed with 1million options ;)
  • Database console needs some polish and error corrections: If I try to modify an entry in a result view, I get an error that a primary key was missing. Using directly the SQL input console works without problems...
  • Some keybindings- with "Alt" are a bit problematic under Linux (Gnome/Compiz) like Strg-Alt-L which will start the login-screen in Gnome and is also the key to format the file in PhpStorm ;)



You are on the right way to bring the top and most recommended PHP IDE. Most features, the working flow etc. can hold the candle without problems to Netbeans or Zend/PDT and are often miles ahead. B-)

[Edit]
This big CPU usage is everytime when settings are changed. Opening settings again (eg. not from the toolbar but from the main menu) will stop the CPU usage but only for this time. (JDK: 1.6.0_22)

Nachricht geändert durch Frank Arnold



Attachment(s):
PS-98.350_devarni_14.11.2010_16.27.59.zip
4 comments
Comment actions Permalink

if you look in the settings under SETTINGS -> KEYMAP ->KEYMAPS (dropdown) there is a default keymap set for gnome, kde and also others in there too like the eclipse keymap.

To fix your gnome issues, change the keymap to "Default for gnome".

Might also like to vote on this issue: "export any keymap to cheat sheet"
http://youtrack.jetbrains.net/issue/WI-3771

0
Comment actions Permalink

This is a good hint! The KDE map has working keybindings (alt-shift instead strg+alt).

Hopefully they find a solution for the CPU problem. This a showstopper.

For the CPU usage I found another thing:
This starts after the change of settings eg. debug settings. This time the toolbar button is not useable again, to open the settings again I must used the menu option...
Opening the settings will stop the CPU usage but only the time the settings dialog is open.

0
Comment actions Permalink

Same CPU usage problem for me on Mac OS X. And for me too, opening the Settings panel reduces the CPU usage only while it's open.

Tangentially, pressing the "Select Debug/Run Configuration" popup does not bring up the popup menu for me. However, as soon as I open the Settings panel, this popup menu also opens.

0
Comment actions Permalink

It seems that the high CPU usage is gone with build 364 B-)

Can somebody confirm this for Linux and MacOS?

0

Please sign in to leave a comment.