External Directories In Project View?

I have two copies of the same project (one is a CVS branch.) They both use the same includes (from php.ini), but one shows them in the Project view and the other does not. Why is that? How do I get that out of the Project view?



Attachment(s):
project_view_problem1.JPG
6 comments
Comment actions Permalink

Hi Keith,

I'm sorry in advance for asking such dumb question but are those folders are actually listed in Settings | PHP in your problematic project?

If the entries are actually there -- you will have to manually edit your workspace.xml file a bit (I had similar issue once and that is how I fixed it).

0
Comment actions Permalink

Maybe this setting?

<showLibraryContents ProjectPane="false" />

0
Comment actions Permalink

OK. Open your workspace.xml file and search for <showLibraryContents -- I have only 1 occurance -- should be under component[name="ProjectView"] > navigator.

Most likely it will look like <showLibraryContents Display="false" /> (sorry, cannot say 100% as it was over 2 month ago.)

The proper value should be just <showLibraryContents />

0
Comment actions Permalink

Actually, before you posted, I added that line (<showLibraryContents ProjectPane="false" />) to the one that was not working and that fixed the problem.

Can someone at PHPStorm explain how that happens? Is that a setting (that I can't find, I've looked...a lot.)

0
Comment actions Permalink

Well, I had my problematic project created with v1 EAP somewhere back in May or June. From what I remember it happened after I was adding/removing additional content roots in Settings | Directories -- at least this is what I think was a reason in my case.

0

Please sign in to leave a comment.