PS.98.191 JavaScript Code Completion unusable

Hi,

I have been trying to use PhpStorm to edit JavaScript (jQuery and jQuery UI libraries), but the IDE has been throwing errors every time it tries to use code completion for JavaScript objects.  The error causes about 5 seconds of lag in the IDE, of which I cannot type or interact with the program. The only solution I have found is to turn off JavaScript support entirely, but then I lose color syntax. Is there anyway to turn off javascript code completion and leave on colored syntax?

I have reported the internal IDE error to JetBrains several times.

Thanks

3 comments
Comment actions Permalink

Andrew,

  I am still using 98.145 so I tried that and it seemed fine.

  Next I tried it in version 98.191 and auto complete was pretty quick, but threw an exception after I made a selection - was this the 5 second delay you wrote about?

  After that I picked File->Invalidate Caches - I picked the 'Invalidate and Restart' Option.

  I then went back into 98.191 and it was autocompleting with no exceptions - my autocomplete list comes up less than a half second.

  If you have not tried the Invalidate Caches option, please give it a try and let us know if that helped.

  - Jack

0
Comment actions Permalink

Same thing here, tried invalidate several times with no luck the error keeps coming back.... Submitted several reports as well.

Richard

0
Comment actions Permalink

Please see my comment to http://youtrack.jetbrains.net/issue/WI-3671. It should not happen anymore in the new forthcoming EAP. Sorry for the inconvenience.

0

Please sign in to leave a comment.