Surround selection with quotes - How to turn it off?

How to turn off editor's feature to surround selected text with quotes? I know, some users love it very much, but i never had used it before and I expect normal behavior of editor when I'm trying to replace text.

3 comments

I could not find it anywhere in Settings as well. I really think there should be an option added in "Settings | Editor | Smart Keys" for that -- my previous IDEs did not have such feature (or I deliberately turned it off) so I'm not getting used to it. It's a good feature -- I voted for it -- and I like it (especially the ([{ keys ). But I find it a bit annoying/irritating (for myself) when I'm using quote keys '" -- when editing existing text or array keys (must be my typing habits/the way how I type). I personally would like to see a separate option for quote keys (in addition to the must have general option) but I guess that would be too much (too much configuration, too complicated to implement like this)...

0

As minimum there should be option to turn this feature off.
I often write quotes over selected text just to replace him.

1

Please sign in to leave a comment.