Git not picking up changes from PhpStorm

Hi,

I have a reproducible issue with integrated git: when I deliberately change a file under version control and try to commit from the command line git picks up the change. However when I run Git->Commit on my project root folder from the IDE I get the message "No changes detected.", whatever I change. The IDE can start git and there are no error messages in the Version Control tab.
There is one incident that might not be related: The IDE used to be able to start git from the path. This stopped working and I had to point the IDE to the full path of the git binary.

Hope someone can help out. Let me know if you need more details.

Best,

Dirk Louwers

3 comments
Comment actions Permalink

in your IDE did you hit the 'synchronize' button (third from the left on the tool bar. looks like refresh) before trying the 'Commit directory'?

The syncronize button refreshes the files in the IDE with those from the file system

0
Comment actions Permalink

I had the same problem en eventually solved it.

First, your root is probably set to the project root and not the git root. Click on the red circle with the exclamation point, on the right side of the status bar. The root issue is pointed out. Select the right path (the bold one, not the striked through one).

From now on all changes will be detected, not the changes already made. So you have to undo these changes and apply them again.

Now you can commit your changes.

Hopefull Jetbrains will make PHPStorm more intelligent about this.

0

Please sign in to leave a comment.