Debugger help MAMP 1.92 on Mac OSX 10.6.4

Hi,

  I could use some help getting PHP debugging working.

  When I click Debug, It runs my code without stopping at breakpoints.

  I am running PHPStorm EAP 98.108 on Mac OSX 10.64 with MAMP 1.9.2 using PHP 5.3.2

  I've enabled debug logging in the idea.log, and have attached the log file.

My php.ini looks like this:

[xdebug] zend_extension="/Applications/MAMP/bin/php5.3/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so" xdebug.file_link_format = "txmt://open?url=file://%f&line=%l" xdebug.default_enable On ;zend_extension_nts="<path to php_xdebug.dll>" xdebug.remote_enable=true xdebug.remote_port="9000" xdebug.profiler_enable=1 xdebug.profiler_output_dir="\Applications\MAMP\tmp>" [Zend]

; this section is empty - zend optimizer does not work with php 5.3.2


edit: I've take an short 18 second video of the behavior
http://www.screencast.com/t/odmQ93Xp6

edit2: After the page displays, I am able to make a connection via command: telnet localhost 9000
(This doesn't help me directly, but I saw it in a few other forum posts so I thought I would mention it)

edit3: The debugger appears to work with PHPStorm 1.02, but not 98-108 - could this be a EAP related issue?



Attachment(s):
idea.log.zip
8 comments

If Anyone can comment/help I would appreciate it greatly!

Is anyone debugging on OSX with the 98.108 EAP release?

0

Hi, Jack!

It looks like EAP problem.

http://devnet.jetbrains.net//docs/DOC-1202#cf - please follow this instruction to help us in investigation of your problem.

Thanks for screencast!

0

Hi Jack,

I'm having kind of similar issue with debugger in 98.108 build -- it's unusable for me right now (using Windows 7, IIS 7.5, PHP 5.3.3, Xdebug 2.1). In particular -- I do not see the current execution line + debugger ignores all breakpoints + another one (with frames -- "<invalid frame> ({main})"  ). AFAIK they already been fixed (see tracker), so I'm just waiting for next EAP build.

The only way when I've managed to have debugger to kick in -- is when I select "Break at the first line" option in Run/Debug Configurations | Debug tab (I'm using "PHP on Server" configuration type). You may need to restart debugger session after such change.

0

Thanks both of you for your replies!

It is nice to know I am not the only one.

I will watch for the next EAP.

0

Nikolay -

  That is the document I followed when creating the post -
  I cleared my idea.log, then re-created the problem, and attached the idea.log file to the post.

  Let me know if there is anything else you need.

  I am always open to a screen sharing session with Skype if that would help.

- Jack

0

Hi Jack,

I just did a quick test with the latest EAP build (98.145) and it looks like all issues which I had have been fixed now (at least I was able to debug simple script with no issues so far).

0

Thanks Andriy,

   I can confirm the same here - It's going to be awesome having that new code complete feature, along with debugging!

- Jack

0

Please sign in to leave a comment.