Question about "Cannot resolve directory"

Hi!

First I must say that, for the first time of my programmer career I'm really impressed by an IDE and I really believe that I'll stick with it a really long time! Good job.

So the problem I'm having is: in every file references that I have in HTML or CSS files, there's an error telling me that the IDE isn't able to find the file. Correct.

The problem is that I use the "Symfony PHP Framework" and my ressources are all located in /web so when I specify in a CSS file /images/test.gif it should go search in /web/images/test.gif for it.

I tried to tweak the directory mapping in the Deployment options but never got it working.

It's my only issue with the IDE so far, two weeks without swearing at NetBeans or any other huge and slow app.

Thanks for your help in advance!


- Tom

3 comments

Hello Tommy,

Marking your "/web" folder as a Resource Root at File | Settings | Directories page should help.

Regards,
Kirill

0

Thanks to both of you! Straightforward and very useful! It worked :)

0

Please sign in to leave a comment.