PHP debug under MAMP is not working for me!

I'm really sorry for opening another discussion this debugging issue. But I've been through a lot of them and none of them solved my problem.

My problem is, that the debugger does not stop at any breakpoints! In other works it doesn't work! When I hit start debugging, the browser pops up, and the php runs without stopping. The settings are in the attached two png-s.

Any help would be appreciated!



Attachment(s):
phpini.png
debugconfig.png
6 comments

Hello Gabor,

The first thing I'd suggest is to turn Zend optimizer off, since AFAIK Xdebug can't cooperate with it.

If that does not help, we need to look at the logs: http://devnet.jetbrains.net/docs/DOC-1202.

Regards,
Kirill

0

Hi, Kirill,

thanks for the reply. Unfortunately turning off the Zend optimizer does not work.

Here's my log.



Attachment(s):
log.png
0

Gello Gabor,

Unfortunately, log file you provided does not contain low-level information we need.
Please check that you've done all the steps correctly.


Regards,
Kirill

PS Please attach complete log file if possible. 'Attach files' field is at the bottom.

0

Hi Kirill,

you're right, I didn't change the category_name to com.jetbrains.php.debug in the log file (I hope this is the right setting).

I tried to debug with two kinds of configuration:
1. wait for Xdebug connection with ide key - nothing happens, the message is that it's waiting for connection on port 9000 and the program doesn't run.
2. open web page in browser - no message but the program runs without stopping at the breakpoints.

Thanks.



Attachment(s):
idea.log.zip
0

Kirill,

I figured it out! You were right about the Zend Optimizer, I just thought that I had turned it off, now after it being off everything works as a charm.

Thanks!

0

Hello Gabor,

Thanks for confirming!

Regards,
Kirill

PS Once you get it you may turn off 'Validate Xdebug config before debug' option at run configuration page. It will make debug starting a bit faster. You can do it for template configuration so that every new instance will have it off as well.

0

Please sign in to leave a comment.