PHPUnit Tests Configuration "All in Directory"

Hi!

I have some test classes in a directory and subdirectories. When I use the configuration "class or suite" or the configuration "method" the selected tests will run. But when I use "All in Directory" I get the Error "No tests were found".

What am I doing wrong?

5 comments
Comment actions Permalink

Hello Sebastian,

Can you please attach a screenshot of your run configuration dialog along with the execution log: steps to take logs are here, you need to specify 'com.jetbrains.php' as category_name.
Unfortunately, logging may miss some important messages when you running tests, and should be complete when you debugging them, so latter is preferred (this problem will be fixed in PhpStorm 1.0.2 build that will be available soon).

Thanks,
Kirill

0
Comment actions Permalink

Hi!

Sorry for the late answer. :-) Now, here is it!

I have tried three configurations and added the screenshots and the log as a zip. I hope you can help me. Maybe I have an error in my configuration?!


Thank you!



Attachment(s):
log.zip
0
Comment actions Permalink

Hello Sebastian,

Thanks for screenshots and logs,

Looking at PHPUnit command line that PhpStorm I see that problem may be in test groups configuration - can you please give a screenshot of the second tab?

Regards,
Kirill

0
Comment actions Permalink

Yes, I can. :-)

Again, I've tried every possibility.



Attachment(s):
test-groups.PNG
0
Comment actions Permalink

Hello Sebastian,

The problem I see is in the file names. By default, PHPUnit supports the following suffixes: 'Test.php', '.phpt', so that 'Foo.Test.php' will be run while 'Foo.Tests.php' will be merely ignored when scanning for test files. Please try to rename your files to check this.

PhpStorm 1.0.1 does not support overriding this setting. Please file a request at http://youtrack.jetbrains.net/issues/WI if you feel it should.

Regards,
Kirill

0

Please sign in to leave a comment.