FTP doesn't list/transfer files; Copy option?; SVN version?

1.
I set up a Remote Host successfully (in that WebIDE says it is successful and autodetects htdocs root), but no file listing appears in the Remote Host pane, and when I try to download or upload the File Transfer pane says "No files or folders found to transfer".

The host is Novell Netware. (S)FTP works fine on a Linux remote host.

Is there a debugging option or log file I can look at.

2.
We map drives to our webserver filesystems. Is there any way within WebIDE to copy files to the mapped drive instead of uploading through FTP? The ideal situation for us would be this:
- Edit file
- Hit key combo which performs user defined actions such as syntax check, formatting, send email, make a sandwich, copy to mapped drive, opens page in browser

3.
Because the rest of the team uses Dreamweaver, we are forced to use Subversion client 1.4. What client version does WebIDE use? Is there a way to specify a different SVN client or version in WebIDE?

Thanks.

16 comments

There will be separate response regarding FTP.  As for SVN - All IntellJ platform based products do not use external client and support SVN natively (Up to version 1.6)

0

Thanks. For #2 I just wrote an external tool to do what I want.

0

Hello David,

but no file listing appears in the Remote Host pane

How does Remote Host view look? Does it display an error message or shows root node?

the File Transfer pane says "No files or folders found to transfer"


You need to setup mappings between your local and remote folders. Web IDE will use these mappings when uploading/downloading the files (and opening server pages in browser). Please open Settings dialog and go to Remote Deployment screen.

Regards,
Kirill

0

the Remote Host view is empty. there is no error message. see screenshot. other ftp clients work fine (see below for manual connection transcript). perhaps it is an older ftp server type that webide cannot recognize. I have set up the mappings. I think webide just isn't getting the directory listing because now when i try to upload it tries to create folders on the web server which already exist.

maybe this will help?


dev:~ # ftp web.domain.com
Connected to web.domain.com.
220-Mega Corp
220-
220-UNAUTHORIZED USE IS PROHIBITED.
220 Service Ready for new User
Name (web.domain.com:root): abc123
331 Password Needed for Login
Password:
230 User abc123 Logged in Successfully
Remote system type is NETWARE.
ftp> rhelp
214-The following commands are recognized ( * denotes Unimplemented Command)
214-    USER    PASS    CWD     XCWD    CDUP    QUIT    PORT    PASV    TYPE
214-    RETR    STOR    REST    RNFR    RNTO    ABOR    DELE    RMD     XRMD
214-    MKD     XMKD    PWD     XPWD    LIST    NLST    SITE    SYST    HELP
214-    STAT    APPE    MDTM    SIZE    NOOP    MODE    STOU    *ALLO   *ACCT
214-    *SMNT   *REIN   STRU    AUTH    PBSZ    PROT    *CCC    *ADAT   *MIC
214-    *CONF   *ENC
214 End of Help



Attachment(s):
jetbrains-remotehost.PNG
0

Hello David,

Please take the FTP logs:

1. open <WEBIDE_HOME>/bin/log.xml with a text editor
2. scroll to the bottom, add the following lines before <root> tag:

  <category name="com.jetbrains.plugins.webDeployment.ftp">
    <priority value="DEBUG"/>
  </category>


3. restart Web IDE
5. Open Remote Host view


By default the log is at ~/.WebIde10/system/log/idea.log on Windows and Linux and at ~/Library/Caches/WebIde10/log/idea.log on Mac.

Thanks,
Kirill

0

I have the similar problem to connect to FTP server and list the file contents.

Here is DEBUG information from log file:

2010-07-03 13:57:06,396 [  33171]  DEBUG - ains.plugins.webDeployment.ftp - 220-*****************************************************
220-Welcome to FTP
220-Please use your email address and password to login.
220-If you are registered for more than one site then your login name must be: yourcompany.com/you@youremail.com.
220-*****************************************************
220-
220 FTP Server Ready
2010-07-03 13:57:06,399 [  33174]  DEBUG - ains.plugins.webDeployment.ftp - > USER yourcompany.com/you@youremail.com
2010-07-03 13:57:06,422 [  33197]  DEBUG - ains.plugins.webDeployment.ftp - 331 User yourcompany.com/you@youremail.com logged in, needs password
2010-07-03 13:57:06,422 [  33197]  DEBUG - ains.plugins.webDeployment.ftp - > PASS ******
2010-07-03 13:57:07,541 [  34316]  DEBUG - ains.plugins.webDeployment.ftp - 230 Password ok, FTP server ready
2010-07-03 13:57:07,542 [  34317]  DEBUG - ains.plugins.webDeployment.ftp - > TYPE I
2010-07-03 13:57:07,565 [  34340]  DEBUG - ains.plugins.webDeployment.ftp - 200 Binary transfer mode active.
2010-07-03 13:57:07,581 [  34356]  DEBUG - ains.plugins.webDeployment.ftp - > SYST
2010-07-03 13:57:07,604 [  34379]  DEBUG - ains.plugins.webDeployment.ftp - 550 Unknown command
2010-07-03 13:57:07,612 [  34387]   WARN - loyment.ui.WebServerConfigForm - Could not list the contents of folder "ftp://yourcompany.com/".
org.apache.commons.vfs.FileSystemException: Could not list the contents of folder "ftp://yourcompany.com/".



I'm connecting with other FTP clients like FIleZilla and CuteFTP and have no problem list / upload files.

Is there a way to edit FTP commands which are used to list files on FTP server or is there any other ideas how could I fix this error and connect to th FTP server?

Thanks in advance,
Rento
0

Hello Rento,

thanks for logs,

You server seems to have SYST command disallowed (probably for security) - you can confirm this by checking that

Caused by: org.apache.commons.net.ftp.parser.ParserInitializationException: Parser key cannot be null

message is in your log file right after the part you've put here.

Currently PhpStorm issues SYST command when connecting to figure out the  OS that server is running, and parse the result of LIST command accordingly (different OSs may give results in slightly different way).

This is likely we need to fix, i.e. expecting some default LIST results format. I've opened an issue for that: http://youtrack.jetbrains.net/issue/WI-2475, please watch/vote to be notified when it's fixed. The only current workaround I see is to allow SYST command on your FTP server.

Regards,
Kirill

0

I'm having the same problem with FTP, the remote host panel is empty, but that seems caused by a timeout problem.


2010-08-05 16:39:08,936 [  22611]  DEBUG - ains.plugins.webDeployment.ftp - 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 57 of 400 allowed.
220-Local time is now 07:39. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
2010-08-05 16:39:08,938 [  22613]  DEBUG - ains.plugins.webDeployment.ftp - > USER *******************
2010-08-05 16:39:09,472 [  23147]  DEBUG - ains.plugins.webDeployment.ftp - 331 User ******************* OK. Password required
2010-08-05 16:39:09,473 [  23148]  DEBUG - ains.plugins.webDeployment.ftp - > PASS ******
2010-08-05 16:39:10,002 [  23677]  DEBUG - ains.plugins.webDeployment.ftp - 230-User ******************* has group access to:  31936   
230 OK. Current directory is /
2010-08-05 16:39:10,003 [  23678]  DEBUG - ains.plugins.webDeployment.ftp - > TYPE I
2010-08-05 16:39:10,372 [  24047]  DEBUG - ains.plugins.webDeployment.ftp - 200 TYPE is now 8-bit binary
2010-08-05 16:39:10,373 [  24048]  DEBUG - ains.plugins.webDeployment.ftp - > CWD /
2010-08-05 16:39:10,792 [  24467]  DEBUG - ains.plugins.webDeployment.ftp - 250 OK. Current directory is /
2010-08-05 16:39:10,821 [  24496]  DEBUG - ains.plugins.webDeployment.ftp - > SYST
2010-08-05 16:39:11,185 [  24860]  DEBUG - ains.plugins.webDeployment.ftp - 215 UNIX Type: L8
2010-08-05 16:39:11,200 [  24875]  DEBUG - ains.plugins.webDeployment.ftp - > PORT 1,90,15,49,177,125
2010-08-05 16:39:11,592 [  25267]  DEBUG - ains.plugins.webDeployment.ftp - 200 PORT command successful
2010-08-05 16:39:11,593 [  25268]  DEBUG - ains.plugins.webDeployment.ftp - > LIST -a
2010-08-05 16:39:32,952 [  46627]  DEBUG - ains.plugins.webDeployment.ftp - 425 Could not open data connection to port 45437: Connection timed out
2010-08-05 16:39:32,954 [  46629]  DEBUG - ains.plugins.webDeployment.ftp - > PORT 1,90,15,49,202,165
2010-08-05 16:39:33,224 [  46899]  DEBUG - ains.plugins.webDeployment.ftp - 200 PORT command successful
2010-08-05 16:39:33,225 [  46900]  DEBUG - ains.plugins.webDeployment.ftp - > LIST -a
2010-08-05 16:39:54,532 [  68207]  DEBUG - ains.plugins.webDeployment.ftp - 425 Could not open data connection to port 51877: Connection timed out
:


what's strange is that another FTP client (Filezilla) works just fine:

Response:    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:    220-You are user number 44 of 400 allowed.
Response:    220-Local time is now 07:35. Server port: 21.
Response:    220-This is a private system - No anonymous login
Response:    220 You will be disconnected after 15 minutes of inactivity.
Command:    USER ********************
Response:    331 User ******************* OK. Password required
Command:    PASS **************
Response:    230-User developer@dev.maddai.com has group access to:  31936   
Response:    230 OK. Current directory is /
Command:    SYST
Response:    215 UNIX Type: L8
Command:    FEAT
Response:    211-Extensions supported:
Response:     EPRT
Response:     IDLE
Response:     MDTM
Response:     SIZE
Response:     REST STREAM
Response:     MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:     MLSD
Response:     TVFS
Response:     ESTP
Response:     PASV
Response:     EPSV
Response:     SPSV
Response:     ESTA
Response:     AUTH TLS
Response:     PBSZ
Response:     PROT
Response:    211 End.
Status:    Connected
Status:    Retrieving directory listing...
Command:    PWD
Response:    257 "/" is your current location
Command:    TYPE I
Response:    200 TYPE is now 8-bit binary
Command:    PASV
Response:    227 Entering Passive Mode (64,13,238,111,217,131)
Command:    MLSD
Response:    150 Accepted data connection
Response:    226-ASCII
Response:    226-Options: -a -l
Response:    226 44 matches total
Status:    Directory listing successful


Regards,
Alessandro Curci

0

Hello Alessandro,

Can you try connecting with 'Passive mode' option enabled at File | Settings | Deployment | (your FTP server) | Advanced options... dialog?

Regards,
Kirill

0

Thanks Kirill,
passive mode did the trick, and found that Filezilla uses passive too as it can't retrive directory listing when forced to active.

Best regards
Alessandro

0

Shouldn't PhpStorm catch this issue and resolve it in the same way as Filezilla does?

0

Hello Dmitriy,

Well, the reason (firewall blocking data connection) is hard to detect with certainty, so usually FTP client applications let user choose connection mode.

Regards,
Kirill

0

But Alessandro said that Filezilla can catch this problem...

0

I haven't said it can catch the problem, but just that it doesn't woork too when forced to active.
FIlezilla worked "out of the box" because the default setting that new connections inherit from the general settings is passive (marked as recomended too).

Regards

Alessandro Curci

0

Ahh, Kirill, sorry, i'm wrong in this case.

0

Please sign in to leave a comment.