Suppress the Lightbulb?

I really like PhpStorm, and we've just ordered a couple of licenses here.  The one thing I haven't been able to configure is removal of the popup lightbulb menu.  It frequently gets in the way when I'm trying to select regions, and I never look at the menu it offers.

Does anyone know if there is a way to have the menu stop appearing without disabling the syntax/intention checking altogether?

5 comments
Comment actions Permalink

Hello David, you may configure all intentions to appear on Alt-Enter only. All you need to do is to uncheck all intentions in File|Settings|Intentions.

0
Comment actions Permalink

Thank you for your help, but unfortunately it still appears.  I unchecked all in File->Settings->Intentions, pressed Apply and Ok, then did the same thing in PhpStorm->Preferences->Intentions.  I quit PhpStorm and restarted to see if that would help.  I still see a lightbulb pop up at the left side of the code when I click in the text.  It seems to appear almost randomly, in different places in the same file, and only appears when I click.  I can't detect a pattern.  I guess I don't really understand intentions.

0
Comment actions Permalink

What actions are suggested? I assume that you see syntax highlighting fixes which would appear anyway ;/

BTW You can tweak "silent period" - File|Settings|Editor|Autoreparse delay.

0
Comment actions Permalink

I've attached a partial screenshot.  I unchecked all the Language Injection options as well, but am still getting this menu.
Thanks again for your help.



Attachment(s):
intentions.gif
0
Comment actions Permalink

http://youtrack.jetbrains.net/issue/IDEA-55203
"Language Injection intention actions are not shown in Intentions UI" problem will be addressed by 9.0.3.

Gregory Shrago

0

Please sign in to leave a comment.