HTML auto attribute rules

Hello,

I accidently clicked something after typing <script and now it no longer automatically completes <script type="text/
Does anybody know where these settings are and how I can put it back? hehe.


Also when typing <br[space] it shows a list of attributes, pressing escape leaves <br ="" on the page. Any way to get [esc] to remove the auto completed text?

Cheers,
Dave

2 comments
Comment actions Permalink

Go to Intentions -> XML in IDE Settings and enable the 'Insert namespace prefix' option to get type="text" back (see screenshot)
Screen shot 2010-07-14 at 22.02.46 .png
the ="" after a <br is a known behavior, even intended actually. The fastest way to get rid of it is to hit 'Undo' (Ctrl-Z/Cmd-Z)

0
Comment actions Permalink

Issue for problem with extra text inserted during completion : http://youtrack.jetbrains.net/issue/IDEA-56593

0

Please sign in to leave a comment.