Debugging - Remote Server (Local SVN Checkout)

I'm trying to setup debugging on a remote server again.  This time I've checked out my repo to my local machine rather than a drive on the remote machine.  I'm still uploading the files to the remote machine, and launch the site against the site hosted on the remote machine.

I'm having a problem figuring out what I need to enter for "Start URL"  There isn't a "Custom web path" and I have no idea what to enter for "Matching local path"  I tried the directory to the checkout and I get this message, "Local path [...] is not mapped."

So then I went into "Server path mappings..." and tried entering the local and remote paths.  This doesn't seem to get me anywhere.  If I can get some help sorting this out I would be extremely greatful.

You might find that I was able to get deubgging working before, but this time I can't seem to figure out what to input.

10 comments

I figured it out.

Under Preferences->Deployment->Mappings: I needed to set Web Path to / which to me seems very strange.

However, I am now getting a strange error I haven't seen before:

Validation failed: HEAD method failed for "http://develment/PhpStorm-a25da36c-b39b-4abb-9d9c-fe7e9ecab531.php?port=6666&sessionId=a25da36c-b39b-4abb-9d9c-fe7e9ecab531"

0

Figured it out... forgot to add php_value and remove the = in my .htaccess file.

0

Debugging seems to be working, however, I can't seem to get it to show the execution point.  I've tried clicking "Show Execution Point"  I've tried putting a break point at the very first line in the application.  Nothing seems to work.

0

Does debugger setup validations give you any messages on start?

0

Hello Chris,

Thanks for your feedback,

Under Preferences->Deployment->Mappings: I needed to set Web Path to / which to me seems very strange.

If your local path maches server root, corresponding web path (relative to server root path) should be ser to /. Why does it seem strange, what value do you expect to set here?

Validation failed: HEAD method failed for....

When validating debugging configuration, PhpStorm puts a diagnostic PHP page on server and retrieves it via HTTP. This error message means that for some reason retrieval failed. We surely need to make it more friendly: http://youtrack.jetbrains.net/issue/WI-1965.

0

Chris,

Please check there are no entries in 'Server path mappings' dialog.

If that does not help, please provide debugging log: http://www.jetbrains.net/devnet/message/5243846#5243846, log file is found at ~/Library/Caches/WebIDE10/system/logs/idea.log on OS X.

Regards,
Kirill

0

Sorry it's taken me a bit to respond, I've been slammed with work...  Here's the latest update...

I get a Browser window that opens with "?XDEBUG_SESSION_START=PhpStorm1" on the end of the URL.

I get the message in the IDE that says, "Waiting for connection on port 9336 with ide key 'PhpStorm1'"

The web page just hangs and hangs.

In my IDE I have...

The Server "Mappings" are as follows:
   Local Path: "Users/username/..."
   Deployment Path: "product" (it's just the path of the product since the server base path starts at the root or the products.)
   Web Path: "/"
"Matching local path:" points to my local checkout starting with "Users/username/..."
Brower: Firefox
"Server path mappings..." has nothing set.
"Validate Xdebug configuration" checked.


Having said all of that...


I enabled debugging by adding the info to my log.xml and it started working.  I'm not sure what to say about that!  Haha!

0

Hello Chris,

Do you mean you just enabled logging at it started working? This is unexpected behavior, you probably made some minor changes (up to server restart?) that solved the problem.

I suggest you not to turn off the logging for the time (although it consumes some disk space and slows down a very bit), so if the issue appears, you can immediately provide it.

Thanks,
Kirill

0

Yes, I'm wondering if there was something cached that cleared out when I enabled logging.  I'm not sure what else it could have been at this point.  The order of events was that I set everything up tried to debug, it didn't work I came here and posted the log and then realized I hadn't turned on the debugging.  So I went back turned on debugging in the log.xml and then attempted to debug again to generate the logs and it worked.

For now I am definitely leaving it on, however, each time I update to the latest release it seems to revert the change.

0

Hi Chris,

For now I am definitely leaving it on, however, each time I update to the latest release it seems to revert the change.

I'm sure debugging won't break once you turn it off.

--
Kirill

0

Please sign in to leave a comment.