Debugging issues on Linux

Gday All,

I have just started using PhpStorm and so far its really good! I was a big fan of ReSharper so this was a natural choice for PHP dev!

I am having problems getting the debugger to work. I have looked though the other posts related to this issue to no avail!

My system is:

Ubuntu 10.04
Apache/2.2.14
java version "1.6.0_20"
PHP 5.3.2-1ubuntu4
Xdebug v2.1.0rc1

I can currently debug without problems in Netbeans so my php.ini settings are fine.

However with PhpStorm I get a continual message "Waiting for connection on port 9000 with ide key "PhpStorm1"

Also, when I try and connect to the debugger via http://localhost/index.php?XDEBUG_SESSION_START=PhpStorm1

I get the following message in Chrome:

This webpage is not available.

The webpage at http://localhost/index.php?XDEBUG_SESSION_START=PhpStorm1 might be temporarily down or it may have moved permanently to a new web address.

More information on this error
Below is the original error message

Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.


2 comments

Hello Michael,

What if you take a plain URL with no debugging parameter (i.e. http://localhost/index.php) and open it in browser? Does it show up?

Also please check the 'Validate Xdebug configuration' checkbox at your PHP on Server run configuration dialog and provide validation results (a dialog will appear if some errors/warnings found).

Thanks,
Kirill

0

Gday Kirll,

If I navigate to  http://localhost/index.php without the xdebug paramater the website loads fine, which is phpinfo.

If I check 'Validate Xdebug configuration'  and try and debug I get the following message:

Validation Failed:
error running diagnostic script

Update: I reverted my xdebug from rc1 to the one shipped with Ubutnu and updated my Java to Sun Java and it seems to have solved the problem.

Regards,
Michael

0

Please sign in to leave a comment.