php debugging windows socket error JVM_Bind

Hello,

I can't start the php debugger in phpStorm. At the very beggining it throws me an error: "Unrecognized Windows Socket error: 0: JVM_Bind". I'm running on windows 7 64bit with WAMP.

8 comments

Hello Piotr,

By default PhpStorm is using port 9000 for debugging. Please check that no other application uses this port (you can use 'netstat' tool for it). You can change the debugging port setting (File | Settings | PHP | Debug), but don't forget to update xdebug.remote_port parameter in your php.ini accordingly.

Regards,
Kirill

0

Unfortunately it's not it. I've tried to change the port to 8080 (zend debugger works on it and it works). I would really like to change to phpstorm instead of aptana IDE but without debugging tools I won't be able to.

0

How much network interfaces do you have? Do you have UAC eanbled? Did you let PhpStorm access through windows firewall? Do you reconnect to several networks (i.e. with notebook)?

0

UAC is disabled.
PhpStorm has access to the internet.
And my computer is a desktop PC and it's connecting only with one private network.
I use only one physical network interface although I have vmware installed so I have 2 other virtual interfaces.

I just want to say, that on aptana xdebugger is working perfectly.

0

Piotr,

Sorry for asking again: do you mean other Java applications successfully start  debugging on the same port PhpStorm fails to? And changing port does not help?

Which version of Java do you use?

Thanks,
Kirill

0

Yes, I normally use Eclipse with Aptana (and I suppose it is a java application?). Xdebug works on that configuration without any problem on port 9000. It's the same for Zend Debugger on port 8080.

I use Java SE 6 update 18 (build 1.6.0_18-b07)

0

Hello Piotr,

Can you please update Java runtime to the latest version?

Also, can you please provide the output of 'netstat -a -b' command?

Thanks,
Kirill

0

Yeah! That's it! After upgrading java AND after changing the port, everything worked. Thanks for all help! Cheers!

0

Please sign in to leave a comment.