4 comments
Comment actions Permalink

It means that IDE consider's include argument a dynamic expression with contents not supported by our evaluation engine and thus notifies you that this expression value is not checked. Looks like a bug in this case. Please submit a bug report.

0
Comment actions Permalink

Done: http://youtrack.jetbrains.net/issue/WI-1576. It was April, 2. But today I opened project and didn't see this warning. And I don't know how to repeat it. The upload.php has been created before April, 2. And it was created in PhpStorm 94.583. And April 1 or 2 I upgraded PhpStorm to 95.17. Maybe it is old cache related issue?

0
Comment actions Permalink

How can I disable this warning?
I'm using a static method class to resolve the full path, ie:

<?php include Kohana::find_file('views', 'admin/system/errors') ?>



So there is no way for phpStorm to figure out the full path.

(Using: phpStorm Beta 1.0 build WI-95.74)
0
Comment actions Permalink

Click on status bar inspector "head" icon to
1) suppress all inspection messages by severity
2) edit profile and disable PHP/Include inspection
Suppressing inspections for individual statements is not available for PHP yet.

0

Please sign in to leave a comment.