JavaScript variable name in purple italics, won't go away

Initially it had Intentions attached to it, but I've disabled them and the JavaScript Intention Power Pack, and the text is still doing this! There is no information on the screen other than the ugly text to indicate which rule/setting is causing this to happen. Please advise. Love this IDE, but just built a new machine and can't remember how to disable some of the more annoying stuff like this.

4 comments
Comment actions Permalink

haven't got what you mean. Please attach a screenshot that shows up your issue (the way variable is displayed plus the "ugly text")

0
Comment actions Permalink

What editor color scheme do you use?
Try changing the 'Global variable' color in Colors & Fonts/JavaScript

0
Comment actions Permalink

Controlled by Settings / Editor / Color Scheme / Javascript / Global Variable.

OR if that setting has CHECKED "Inherit values from: Identifiers->Global variable (Language Defaults), then EITHER UNCHECK, OR click on link to the master setting, and fix it there.

If the setting doesn't seem to match what you are seeing, or changes have no effect when "Apply", then something must be messed up internally. In that case, look near top of Settings pane, for "Scheme: Default" (Or whatever scheme you have selected). To the right is a "gear" icon with dropdown. Select "Restore Defaults". (OK to close Settings, then open Settings again. ...Just to be sure.) This will still have the "purple italics", so you need to do the steps above - but at least now you *will* be able to make changes to the settings.

0

Please sign in to leave a comment.