WebStorm hogging CPU even when idle

I am using webstorm with a node.js project.
The project is big, but not unreasonably big.

From time to time webstorm becomes very slow up to unresponsive.
I notice that webstorm takes lots of CPU (40%-50% is very typical).
I have a reasonably powerful machine.

This must be a setting thing (watchers?), I find that when idle (just have a few files open), even when I scroll up-down in a file, cpu usage can go up to 20% easy.
When typing in a single character into a file (for example a backspace), cpu usage jumps to 40-50% for several seconds.
What is this?
Please don't ask me to just take snapshots because it is a lot of work, and last time you could not deduct anything from that.
Thanks,
Ilan

3 comments
Comment actions Permalink

If you aren't going to provide snapshots, the only thing I can suggest is excluding node-modules from indexing. This can only be done in WebStorm 9 EAP (doesn't work in WebStorm 8);

  • remove library '<module name> node_modules' in "Settings | Languages and Frameworks | JavaScript | Libraries";
  • mark node_modules/ directory as excluded.
1
Comment actions Permalink

How do I take a snapshot?

0
Comment actions Permalink

How to capture the CPU snapshot:
start the snapshot, type something, make some actions in IDE(at least for a minute), then stop the snapshot: https://intellij-support.jetbrains.com/entries/29983118 .

0

Please sign in to leave a comment.