invalid ssh passphrase with git

Hi Everyone,

I have a problem with git integration. I setted my own git repos on my server and i can access, commit, push, pull etc ..... without any problem from my client in command line.
When i try to use phpStorm git integration, everytime it ask me for passphrase and tell me that the passphrase is invalid!
So i am sure that the passphrase is correct (i'm using it everytime)

I have this on the console:


10:48:07.605: cd /var/www/project
10:48:07.606: git fetch origin
SSH: authentication methods: [publickey, keyboard-interactive, password] last successful method:
java.io.IOException: Authentication failed: Invalid passphrase for the key /home/server/.ssh/id_dsa
    at org.jetbrains.git4idea.ssh.SSHMain.authenticate(SSHMain.java:280)
    at org.jetbrains.git4idea.ssh.SSHMain.start(SSHMain.java:155)
    at org.jetbrains.git4idea.ssh.SSHMain.main(SSHMain.java:135)
fatal: The remote end hung up unexpectedly

Thanks for your help

8 comments
Comment actions Permalink

Hello Emmanuel,

Which OS and which version of Git do you use?

0
Comment actions Permalink

git version 1.7.4.1
Ubuntu 11.04 => Linux serveur 2.6.38-13-generic #54-Ubuntu SMP Tue Jan 3 13:44:52 UTC 2012 i686 i686 i386 GNU/Linux
phpStorm 3.0.1

tks

0
Comment actions Permalink

Hi

I had a similar problem with svn under windows and I've tried different ways to solve. The only thing that helped me a check-out repository directly from the webstorm.

Regards,
Dmitry

0
Comment actions Permalink

1. As I see, you're using a DSA key. Can you try with an RSA key (for investigation purposes)?

2. Do you have something similar to pageant on Linux? A method to enter the passphrase only once during the session.
If you do this, does PhpStorm perform remote operations without error?

3. Does the error happen with all remote operations, including checking out a new repository via PhpStorm?

0
Comment actions Permalink

1. Same problem with RSA key:
     i tried first with passphrase and it's failed
     i tried without passphrase and it's working fine

2. I have the same problem with netbeans, i think it's a java problem (?)

3. The error appen with all remote opération.

I also tried with ssh-add before :)


Regards

Emmanuel

0
Comment actions Permalink

Yeah, it might be a problem with underlying Java library which we use to connect over SSH: trilead-ssh2. Probably, Netbeans uses the same lib.

0
Comment actions Permalink

oh crap, i found the problem, my passphrase contain special caracter, i change the passphrase and it's working fine now!

The caracter who make fail is € (euro)

Thanks again and sorry for taking your time

0
Comment actions Permalink

Good to hear the problem is solved.
Good luck :)

0

Please sign in to leave a comment.