Maia-95.4/ MacOS X 10.6.3 - PHP/xdebug not working.


I made sure my xdebug (2.0.5) is working by using Eclipse to step through my php code.  My has this:

xdebug.profiler_enable = Off
xdebug.default_enable = On

I setup my profile on my locally running apache accessible locally at  When I click on "Run" it pops up my Firefox tab with my site at just fine. When I click on "Debug" it pops up the url:  and just hangs with "Waiting for" at the bottom bar of browser.

The Debug pane says: "Waiting for connection on port 9000 with ide key 'IDEA1'"

I've tried different debug checkbox options such as "Open web page in browser(ide key: IDEA1,IDEA2,...)  as well as the "Wait for Xdebug connection with ide key: " and then filled in "IDEA1". For this second option I modified my php.ini and added  xdebug.idekey=IDEA1

nothing has worked so far.  The firewall on my Mac is disabled.     Please help. The debugging used to work with previous Maia versions.

Here is what the xdebug.log says when I launch the Maia php debugger

Log opened at 2010-03-31 23:09:21
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" fileuri="file:///opt/projects/misc/myproject/index.php" language="PHP" protocol_version="1.0" appid="98753" idekey="IDEA1"><engine version="2.0.5"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[]]></url><copyright><![CDATA[Copyright (c) 2002-2009 by Derick Rethans]]></copyright></init>

<- feature_get -i 192 -n supports_async
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_get" transaction_id="192" feature_name="supports_async" supported="1"><![CDATA[0]]></response>

<- feature_get -i 193 -n breakpoint_types
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_get" transaction_id="193" feature_name="breakpoint_types" supported="1"><![CDATA[line call return]]></response>

<- feature_set -i 194 -n show_hidden -v 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="194" feature="show_hidden" success="1"></response>

<- stdout -i 195 -c 0
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="stdout" transaction_id="195" success="0"></response>

<- stderr -i 196 -c 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="stderr" transaction_id="196" success="0"></response>

<- feature_get -i 197 -n encoding
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_get" transaction_id="197" feature_name="encoding" supported="1"><![CDATA[iso-8859-1]]></response>

<- feature_set -i 198 -n max_children -v 100
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="198" feature="max_children" success="1"></response>

<- feature_set -i 199 -n max_data -v 100
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="199" feature="max_data" success="1"></response>

<- feature_set -i 200 -n max_depth -v 3
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_set" transaction_id="200" feature="max_depth" success="1"></response>

<- eval -i 201 -- cGhwX3VuYW1lKCJzIik=
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="eval" transaction_id="201"><property address="140734799802176" type="string" size="6" encoding="base64"><![CDATA[RGFyd2lu]]></property></response>

and then after the browser just hangs with "Waiting for ..." message, I stop the Maia php debugger and this is the message in xdebug.log

<- detach -i 202
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="detach" transaction_id="202" status="stopped" reason="ok"></response>

Any idea ?



Can anyone make any suggestions on how to deal with this ?  Is there any other troubleshooting steps you guys can suggest to figure out whats going on ?



John, let's continue the discussion at YouTrack issue page:



Please sign in to leave a comment.