IntelliJ 90.137 Experiences

Hi all,

I felt adventurous today, so I installed IntelliJ 90.137. After a quick download, and an even quicker install (on Mac OS Snow Leopard), I ran IntelliJ, and everything looked nice. Except for the indexing part. The indexer indexed my Java 1.6 JDK approximately 7 times, cause my project to be valid, invalid, no valid, ehmm, invalid...I decided to give it a rest, and after a couple of minutes (argh) the indexer stopped. I went to the options screen, to see which nice things were added, and when going to the 'file types' part, my IDE got stuck in the option screen. Nothing worked anymore, and the only way to get out of the screen was by killing IntelliJ.

The second time I started IntelliJ, the indexing took place again, but after that, I started browsing through my source code. However, each time I click a source file, I see a spinning loader (or something) really annoying. It pops up, and goes away. The I started clicking through some POM's, and IntelliJ started a background indexing process....again!!! argh! Mind you, this is a 'project' with 20 source files in it, and 3 pom's, but currently, IntelliJ takes around 100% of my CPU time, doing...well, I have no idea what it is doing. I wanted to send a heap dump or something, but I forgot how to do it, and I cannot find the information to do so.

My plan was to give some constructive feedback, but my current experience with IntelliJ 90.137 doesn't allow me to give any feedback and I don't have time to work around all these issues. I hope the next release will work better, then I'll might try again. For now, back to IntelliJ 8.1.3!

Erik

34 comments
Comment actions Permalink

Hello Bas,

Secondly the MaxPermSize is most likely set too low. On a 32 bit JVM
250m is better, and on a 64 bit JVM I would set it as high as 500m.

Both these issue may be a cause for your performance problems.


The comment about MaxPermSize is not exactly true, as far as I understand.
Either you have enough permgen space (then everything runs normally) or you
don't (then everything grinds to a halt).

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hello Dmitry,

yole wrote:

Secondly the MaxPermSize is most likely set too low. On a 32 bit JVM
250m is better, and on a 64 bit JVM I would set it as high as 500m.

Both these issue may be a cause for your performance problems.


The comment about MaxPermSize is not exactly true, as far as I understand.
Either you have enough permgen space (then everything runs normally) or you
don't (then everything grinds to a halt).


I have seen cases where IntelliJ IDEA had apparently enough permgen space to not throw out of memory errors, but acted very slow and periodically unresponsive (probably because the jvm was garbage collecting). Increasing the MaxPermSize specified fixed the issue.

Bas

0
Comment actions Permalink

Here's my current setting:

-Dsun.awt.keepWorkingSetOnMinimize=true
-Xms256m
-Xmx512m
-XX:MaxPermSize=250m
-agentlib:yjpagent=disablej2ee,sessionname=IntelliJIdea90

It's running on Windows XP (32bit) with 94.192/JDK 1.6.18:

java version "1.6.0_18"
Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode, sharing)

So far, I haven't been any OOM exception, the project did take a while to open since I cleared the system directory.  With just a few minutes of using IDEA with the above setting, everything seems ok for now.  But it's a little premature to make any reasonable assessment.  I'll keep things running like this for a few more days.

Thanks again for all who had contributed to this issue!

mike

0
Comment actions Permalink

OK.  I think I'm fairly confident of what's happening now (but, never say never... I could still be wrong).

If I open the project with no files open in the editor, or very few simple files in the editors, then in general intellij9's behavior quite speedily.

Suppose if I left a bunch of files opened (like 20 - 30 files) and exit IntelliJ.  The next time I start up IntelliJ, it becomes noticeably slower. Also, if I open at once 15 - 20 files, IntelliJ seems to behave slower -- not just during the files being open, but the degredation persist for quite some time.  This problem is especially obvious when I'm opening large (more than 500 lines) JSP, XML or properties files.

Again, if I'm working on a small set of files or just Java code, IntelliJ is doing quite well.  Although I must say that "-Xms256m -Xmx512m" seems to be necessary.  Anything less than that would at some point result in OOM or performance issue (as was the case for me with "-Xms128 -Xmx192m").  I wonder why Maia requires so much more memory than its predecessor?  Anyone to shed light on this?

For completeness:
I'm using 94.273/JDK 1.6.0_18/WindowsXP SP2.  Here's my vmoptions:
-Dsun.awt.keepWorkingSetOnMinimize=true
-Xms256m
-Xmx512m
-XX:MaxPermSize=250m
-agentlib:yjpagent=disablej2ee,sessionname=IntelliJIdea90

One more caveat: my project is using IBM JDK 1.5.  Not sure if this matter at all.

Thanks,
Mike

0

Please sign in to leave a comment.