Highlighting of matching selected text...

Answered

I use a dark colour scheme and so I have problems with the highlighting
of the matches to the selected text : see screenshot.

Can you tell me what setting it is that configures the colour used here?
I've looked thru the colour settings but I can't see it :S

Cheers,
N.



Attachment(s):
hilite.gif
12 comments
Comment actions Permalink

For Ctrl+F in the editor:
Settings > Editor > Colors & Fonts > General > Text search result

For CtrlShiftF7 in the editor:
Settings > Editor > Colors & Fonts > General > Search result
Settings > Editor > Colors & Fonts > General > Search result (write access)

Bas

0
Comment actions Permalink

Bas Leijdekkers wrote:

For Ctrl+F in the editor:
Settings > Editor > Colors & Fonts > General > Text search result

For CtrlShiftF7 in the editor:
Settings > Editor > Colors & Fonts > General > Search result
Settings > Editor > Colors & Fonts > General > Search result (write access)

Bas

Thanks Bas...
Unfortunately it's none of these. I'm talking about the highlight that
is done by selecting a piece of text - double-clicking on a word for
instance.
If the default is a white background then people with a white background
probably don't even see it... I'm wondering if it's an incomplete feature...

N.

1
Comment actions Permalink

Bas Leijdekkers wrote:

For Ctrl+F in the editor:
Settings > Editor > Colors & Fonts > General > Text search result

For CtrlShiftF7 in the editor:
Settings > Editor > Colors & Fonts > General > Search result
Settings > Editor > Colors & Fonts > General > Search result (write access)

>

Unfortunately it's none of these. I'm talking about the highlight that
is done by selecting a piece of text - double-clicking on a word for
instance.
If the default is a white background then people with a white background
probably don't even see it... I'm wondering if it's an incomplete feature...


On selecting text? I do not have that (even when I change my background color to gray). Do you have "Settings > Editor > Highlight usages of element at caret" enabled? Or could it be from some plugin?

Bas

Edited by: Bas Leijdekkers on Nov 14, 2008 10:58 AM

0
Comment actions Permalink

Bas Leijdekkers wrote:

On selecting text? I do not have that (even when I change my background color to gray). Do you have "Settings > Editor > Highlight usages of element at caret" enabled? Or could it be from some plugin?

Bas

Edited by: Bas Leijdekkers on Nov 14, 2008 10:58 AM


Hmm... I suppose it could be a plugin... but I don't know which one. I
haven't got the Identifier Highlighter plugin installed which would be
the most likely candidate. And the "Highlight usages..." option has
never worked for me ever since it was introduced - just causes
exceptions, which I've submitted to the tracker.

N.

0
Comment actions Permalink

Nathan Brown wrote:

Bas Leijdekkers wrote:

>> On selecting text? I do not have that (even when I change my
>> background color to gray). Do you have "Settings > Editor > Highlight
>> usages of element at caret" enabled? Or could it be from some plugin?
>>
>> Bas
>>
>> Edited by: Bas Leijdekkers on Nov 14, 2008 10:58 AM


Hmm... I suppose it could be a plugin... but I don't know which one. I
haven't got the Identifier Highlighter plugin installed which would be
the most likely candidate. And the "Highlight usages..." option has
never worked for me ever since it was introduced - just causes
exceptions, which I've submitted to the tracker.

N.


Aha... found the culprit! It was the BrowseWordAtCaret plugin! Thanks
for the suggestion Bas...

N.

2
Comment actions Permalink

Hi!

The BrowseWordAtCaret plugin seems to not have been updated for 5 years and it looks like the functionality of highlighting double-clicked word occurences is already built-in. However, I cannot find where the color of the highlight can be changed (the current one has too little contrast comparing to the background). Could you please help?

0
Comment actions Permalink

Hello,

Please check "Settings/Preferences | Editor | Color Scheme | General | Search results"

0
Comment actions Permalink

This setting affects highlighting of text found by ctrl+F, not by double clicking a word inside the text editor.

0
Comment actions Permalink

Pawel,

Could you please attach screenshot with color you'd like to change? There are two items under "Search Results" - "Search Result" (for double click searches) and "Text search results" (for Ctrl+F).

0
Comment actions Permalink

I too have the same issue and I hop this image helps

The Insertion point is at the word foo in line 4

The highlighted word foo on line 6 does not obey either of the 3 customised settings visible in the settings dialog

0
Comment actions Permalink

Hi MG please try to change the following option:

0
Comment actions Permalink

Thanks, that works as expected/desired

0

Please sign in to leave a comment.