JSP highlighting/code suggestions not working

I have been using the community edition for a while and recently upgraded to the ultimate edition to work on a jsp project.

I am having trouble setting jsp up correctly, If I open an existing jsp file it is basically treated as text. I would like highlighting and code suggestions in a similar way to working on a java project.

When I go to create a new project, or a new file within an existing java project, I do not see JSP file as one of the options. How do I add this?  I am using Intellij IDEA Ultimate 13.1.4

Thanks for your help.

3 comments
Comment actions Permalink

Hi,

Do you have 'JSP Files' in 'Settings | File Types | Recognized File Types'? What extensions are associated with this file type?

0
Comment actions Permalink

I had multiple java 32 and 64 bit JDKs installed and decided to clear it all out and start again, but appear to have created a new problem.

Now when I open a java project (normal java not jsp) although the code will compile successfully, almost all of the commands are coming up in red and when hovering over them it says cannot resolve symbol. I suspect I will need to deal with this problem first before sorting out the jsp problem. Any ideas what I have missed out here?

Back to the jsp issue, when I go to settings > file types I do have an entry Java Server Page files with *.jsp added as a file type, but opening a jsp file gives me the same problem as above.

0
Comment actions Permalink

I have now solved my normal java code problem, the jdk was not linked correctly.

If I open an existing jsp file the code is not really recognized well, but if I start a new empty project, right click on src folder, then click new > edit file templates, go to the Java EE tab and expand "Web" I can see "jsp files" as an option. Clock OK and it creates a default jsp file, and now validates my jsp code in that file.

Now when I go to the new file menu, JSP file is one of the common options.

Thank you for your assistance.

0

Please sign in to leave a comment.