$GWT_HOME not visible inside IDEA on Mac OS 10.6

This is driving me nuts: I set up a Grails project and installed the grails GWT plugin but IDEA doesn't see $GWT_HOME. When I set up the project on the command line, everything works fine.

Any idea how to solve the problem?

Thanks a lot...

Peter

Grails 1.3.6
Grails GWT Plugin 0.52
gwt-2.1.1

4 comments
Comment actions Permalink

I have created Grails project with GWT plugin. All GWT related scripts (e.g. 'create-gwt-event', 'compile-gwt-modules') works fine. Enviroment variable 'GWT_HOME' passes to grails-script successfully. What does mean 'IDEA doesn't see $GWT_HOME'?

0
Comment actions Permalink

I am using GWT within a Grails project and when I try the Grails command run-app I get the following error:

Environment set to development
ERROR: null is not a valid GWT installation.



Thanks a lot for your support,
Peter
0
Comment actions Permalink

May be you disabled "Include parent environment variables" options in Run Configurations. Make ensure that "Include parent environment variables" is enabled.
screen1.png
screen2.png

0
Comment actions Permalink

Hi Sergey
your hint led me to the following solution:


The "include environment parameters" option worked only after I created the file ~/.MacOSX/environment.plist and edited it so that it looks like this:

?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">


<plist version="1.0">
     <dict>
        <key>GWT_HOME</key>
        <string>/usr/share/gwt</string>
     </dict>
</plist>

In this way the environment variable GWT_HOME is passed to any application that is started from the finder.

Instead of defining GWT_HOME for the finder I could have added it to IDEA's "Run / Debug" Configurations but the downside of this solution is that any script triggered by "Run Target" depending on an environment variable such as "run-gwt-client" would fall flat again.

Thanks for you ongoing support

Peter
0

Please sign in to leave a comment.