Turning off reloadable?

Idea seems to be always turning on reloadable regardless of what I have it
set to in server.xml. Is there any way to turn it off?

With class reloading it's not really necessary for me anymore and tends to
stuff things up with tapestry anyway.

-- Glen


7 comments
Comment actions Permalink


Is this one effecting anyone else? I really really want to see this fixed.
This and the bug with not detecting external changes until I close down
idea.


"Glen Stampoultzis" <gstamp@iinet.net.au> wrote in message
news:bu7h85$qnj$1@is.intellij.net...

Idea seems to be always turning on reloadable regardless of what I have it
set to in server.xml. Is there any way to turn it off?

>

With class reloading it's not really necessary for me anymore and tends to
stuff things up with tapestry anyway.

>

-- Glen

>
>


0
Comment actions Permalink

Glen Stampoultzis wrote:

Is this one effecting anyone else? I really really want to see this fixed.
This and the bug with not detecting external changes until I close down
idea.


I'm not sure what you're refering to.

R

0
Comment actions Permalink

What I'm saying is that if you have a context like this:

then idea will change it to reloadable="true" mean means that when you compile your whole webapp is restarted. This is unnecessary when class reloading in debug mode and means I have to do things like login again. Regards, Glen "Robert S. Sfeir" ]]> wrote in message
news:bv5q90$nq3$1@is.intellij.net...

Glen Stampoultzis wrote:

Is this one effecting anyone else? I really really want to see this

fixed.

This and the bug with not detecting external changes until I close down
idea.

>

I'm not sure what you're refering to.

>

R



0
Comment actions Permalink

Glen Stampoultzis wrote:

What I'm saying is that if you have a context like this:

<Context path="/seaview"
docBase="C:/Projects/seaview/main/exploded"
reloadable="false" debug="0">

</Context>


Oh I see. yeah, forgot I can control it this way.

You file a bug?

R

0
Comment actions Permalink

Yes but it's sitting in submitted.

"Robert S. Sfeir" <robert@codepuccino.com> wrote in message
news:bv75ms$k6e$1@is.intellij.net...

Glen Stampoultzis wrote:

>

What I'm saying is that if you have a context like this:

>

<Context path="/seaview"
docBase="C:/Projects/seaview/main/exploded"
reloadable="false" debug="0">

>

</Context>

>

Oh I see. yeah, forgot I can control it this way.

>

You file a bug?

>

R



0
Comment actions Permalink


Hi,

I'd like to turn off Tomcat's automatic reloading as well.

Any news on this one?

The bug seems to be sill in state submitted (assigned).


Best regards,

-Jani

0
Comment actions Permalink

What you can do is run tomcat externally and attach a remote debugger. Not
ideal though.

"Jani Kaarnalehto" <no_mail@jetbrains.com> wrote in message
news:22723886.1077799017970.JavaMail.javamailuser@localhost...
>

Hi,

>

I'd like to turn off Tomcat's automatic reloading as well.

>

Any news on this one?

>

The bug seems to be sill in state submitted (assigned).

>
>

Best regards,

>

-Jani



0

Please sign in to leave a comment.