CLion Watch points not supporting array browsing

Previously I was able to browse through the contents of an array with the watch points. Currently I just have a binary symbol showing up on the watch.

I created a new array to test, and I'm able to browse it, but the previous array even if I rename it remains unbrowsable.

I'm on Arch Linux in case that matters, and have tried different versions of GDB to get the same result.

Pic showing the issue:

Anyone have any idea how to fix this?

Comment actions Permalink

Hi Michael!

Sorry for the delayed response.

Could you please provide a sample project so we can take a look? Also please enable debug logging by entering #com.jetbrains.cidr.execution.debugger into Help | Configure Debug Log Settings, restart the IDE, reproduce the problem and send us idea.log (Help | Show Log in Finder). Do not forget to disable debug logging after that.

Comment actions Permalink

Next time it pops up, I'll make sure to send that over. 


Please sign in to leave a comment.