PHPStorm 10 paste php code issue

If I copy a properly escaped PHP code and paste it, PHPStorm auto escapes it! This is a nightmare and it was not doing this before upgrading to 10.

Example:

$html = "<img src='".$src."' >;

After pasting:

$html = "<img src='\".$src."\' >;

1 comment
Comment actions Permalink

It really depends on context -- what you are copying and where.

If you copy the whole line then IDE will paste as is .. but if you copy only part of it .. then yes -- such behaviour is possible (depends on context actually).

You cannot turn of this new behaviour (there is simply no setting for this). The best *you* can do from IDE side is to use "Paste Simple" instead of "Paste" (hint: you can swap shortcuts around or assign any desired shortcut you want).

Other than that -- feel free to create new ticket at Issue Tracker and provide exact steps with screenshots (what exactly you are copying (which part of the string) and where you pasting it etc).

0

Please sign in to leave a comment.