xdebug 2.4.0RC3 not being recognized in PHPStorm 10.0.3 with PHP 7.0.2

Hi. I understand that this new xdebug (the 2.4 version) is still a release candidate, and that support for PHP 7.0.2 may be a little sparse, but I would like to test both now that I'm coming back to PHP.

So here's my setup:

  • Windows 10 Pro x64
  • PHPStorm 10.0.3
  • PHP 7.0.2 x64 (VC14, non thread safe, since I'm running the built in server from command line)
  • xdebug 2.4.0RC3 x64 (VC14, nts - matching my PHP version)

 

And here's what I've done:

  • Unzipped the PHP package somewhere and added it to the path
  • Put the xdebug dll inside the 'ext' folder inside PHP's directory
  • Edited php.ini to change my extensions directory as to match the location where unzipped the stuff
  • Edited php.ini to load xdebug

 

Running the built in PHP server (`php -S localhost:8000`) works just fine, and a `phpinfo();`will return the correct version at the top, along with "with Xdebug v2.4.0RC3, Copyright (c) 2002-2015, by Derick Rethans". The [xdebug] block is showing correctly as well.

When I run PHPStorm, I can configure it to use the correct PHP interpreter, but it's not then showing the debugger:

So. What am I doing wrong?

Thanks.

1 comment
Comment actions Permalink

Hi there,

Where is has not being recognized? Screenshots please -- as it is recognized here.

  • Windows 7 x64 SP1 ENG;
  • PHP 7.0.2 nts x86 (yes, I'm using 32-bit PHP on 64-bit Windows);
  • xdebug 2.4.0.RC3 (taken here: PHP 7.0 VC14 (32 bit) )

I have also tried 64-bit PHP (and xdebug) -- was recognized just fine (see below). The only difference from your screenshot is that I have OPCache enabled (by I very doubt that it will do any difference here).

I suggest:

  1. Show similar screenshot of what you have got there
  2. Also check and show what you will see when clicking on "(i)" button (the one next to refresh button on my screenshot)
  3. Double check your PHP settings (e.g. "php -v" and even "php -i" in console -- does it throw any errors -- they may prevent IDE from parsing the output correctly).
0

Please sign in to leave a comment.