"Connection refused" exception when running/debugging plugin in sandbox

Answered

Recently, I switched to version 15 as development environment for my plugin. Beside an annoying log4j netty warning that I cannot get rid of, there is another issue that I don't understand. Sometimes when I run or debug the plugin, I get the attached "Connection refused" exception, that I don't understand as I haven't changed anything. Can someone give me a hint in the right direction?

Cheers
Patrick

WARN: Connection refused
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:529)
at java.net.Socket.connect(Socket.java:478)
at java.net.Socket.<init>(Socket.java:375)
at java.net.Socket.<init>(Socket.java:218)
at com.intellij.idea.SocketLock.tryActivate(SocketLock.java:184)
at com.intellij.idea.SocketLock.access$300(SocketLock.java:50)
at com.intellij.idea.SocketLock$2.call(SocketLock.java:124)
at com.intellij.idea.SocketLock$2.call(SocketLock.java:113)
at com.intellij.idea.SocketLock.underLocks(SocketLock.java:157)
at com.intellij.idea.SocketLock.lock(SocketLock.java:113)
at com.intellij.idea.StartupUtil.lockSystemFolders(StartupUtil.java:263)
at com.intellij.idea.StartupUtil.prepareAndStart(StartupUtil.java:101)
at com.intellij.idea.MainImpl.start(MainImpl.java:34)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.intellij.ide.plugins.PluginManager$2.run(PluginManager.java:90)
at java.lang.Thread.run(Thread.java:662)
log4j:WARN No appenders could be found for logger (io.netty.util.internal.logging.InternalLoggerFactory).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
12 comments
Comment actions Permalink

Hi Sergey,

for no apparent reason, I cannot view this issue, when I'm logged on. It doesn't seem to exist in my version of YouTrack :-)

Nevertheless, it seems I didn't screw something up and the fix is on its way. Thanks for your answer.

0
Comment actions Permalink

Sorry, caused by internal visibility of the issue. I've changed it. Please try again.

1
Comment actions Permalink

Yes, now I can see the issue. Thanks

0
Comment actions Permalink

JFYI, the Netty log is gone in IDEA 16, too.

1
Comment actions Permalink

@Roman, that is great!

Btw, since both of you guys have a JB logo in your username: The new forum looks really great, but there are some issues:

  • Where can I accept a comment or answer as "the best answer"? In the list of questions, there is one question that is marked as "Answered" and I have absolutely no idea where I find a button for this.
  • A voting system is great like it is on stackoverflow, but why didn't you copy the Markdown editor as well? I mean, we are all programmers and writing markup is something we can do while sleeping. I don't want to click to insert links or bullet lists. How am I supposed to insert `inline code`?
  • I can upvote my own question which is great, but shouldn't be possible
  • Where do report bugs or ask questions about the community forum itself?

Cheers
Patrick

2
Comment actions Permalink

There is a "Post Actions" link at the top of the page, you'll find "Answered" status there.

Regarding your questions about new forum, I've filed https://youtrack.jetbrains.com/issue/ZEN-58 and https://youtrack.jetbrains.com/issue/ZEN-59. But I'm not sure this youtrack project (ZEN) has public visibility.

0
Comment actions Permalink

@Sergey, I already saw the "post actions" button, but it only lets me select "edit". That's all. Maybe I need a certain amount of reputation.

As I cannot see the ZEN project, can I do something to earn the status of a "viewer" (where I can probably at least comment)?

0
Comment actions Permalink

@Sergey, thanks for filing these issues, the project is internal, but I definitely will take care of them.

@Patrick, thank you for detailed feedback!

1) These questions are normally marked "Answered" by JetBrains support agents to provide better insight on the status of the topic.

2) In this case we are quite dependent on the solution provided by Zendesk and at this point they don't provide Markdown support for Community Comments. We'll look into it as the solution evolves, there have been quite a lot of positive changes recently. In any way, I'll raise this question with them in related topic (which also has their reasoning which might be interesting for you).

By the way, the `inline code` can be inserted choosing "Code" here:

3) Looks like a bug, I'll report it to the solution provider.

4) There is no dedicated place for now to report it and I'm not sure it's needed as the flow of forum-related feedback has been very moderate. You can always reach out to me directly at mikhail.vink [AT] jetbrains.com and I'll be happy to discuss improvements (as I'm responsible for forums project at this point). Posting it to any of the community forums or support channels would work too as my colleagues will tell me about it.

Thank you!

0
Comment actions Permalink

@Patrick, I've marked as Answered. Sorry about the inconveniences of the new forum. Hope @Mikhail will figure out the solution soon.

0
Comment actions Permalink

Thank you all for your valuable input. I really do appreciate the fast responses.

@Mikhail Regarding the inline code issue, your suggestion is exactly what I tried. What happens here (OSX latest, Chrome latest) is that when I mark a word and then try to make it "code", the whole paragraph is turned into code. Let me give an example, where I try to make only 1+1 as code:

Here is the question whether 1+1 really equals 2.

Can you try it yourself? Another thing is the inconsistency between pressing Enter and using Shift+Enter. Here, in a normal paragraph, Shift+Enter means "make a linebreak, but don't leave the paragraph" like
I
could
do
here.

Normal Enter makes a new paragraph. When I have marked text as code, the behaviour is turned around.

Pressing normal Enter
just gives me a new line inside the same "code paragraph" while pressing Shift+Enter

leaves the environment.

The blog post about Zendesk is fun to read as one reason for removing Markdown was feedback from "Agents":

Agents cited tools such as Gmail, Outlook, Word, Google Docs, Hangouts, and of course competitor products which those agents had used. They expected not only visual tools to help them format their content, but expected that content to look exactly as it will when saved.

Well, OK... :-) Anyway, I really like the new forum. It loads very fast and even without Markdown, it is a vast improvement. Thank you for that!

 

0
Comment actions Permalink

@Patrick Thanks a lot! I can indeed reproduce it and will communicate to Zendesk engineers so that it gets fixed at some point. We're going to improve quite a lot of things here (and provide feedback to the platform too), so stay tuned, I hope you'll like it even more :)

0

Please sign in to leave a comment.