Can someone tell me how to get Pygame working in Pycharm start to finish?

Answered

Been wanting to work on learning programming for years. Decided I wanted to work on learning Python 3. After I get a handle on it I was going to move onto creating simple games(Move block around, Simple sentence games w/e) 

I do not want to bother with python if I can not get pygame working on it otherwise I am just going to move onto another simple starting language. Can someone help me because I have been trying to get it working for days and I am pretty fed up with it.

Again trying to get Pycharm to acknowledge Pygames existence.  

7 comments
Comment actions Permalink

I've been using PyCharm with Pygame. First, some questions:

  • What operating system are you using?
  • Are you using binary-installed Pygame or one you built yourself?
  • What version of Python?

Paul Everitt
PyCharm Developer Advocate

0
Comment actions Permalink

i am having the same issue i have tired downloading pygames several different ways and cants get it work!!

0
Comment actions Permalink

@ Paul Everitt

I am seeing the same issue as well.

I have Pycharm 2017.2, with the July 25th build. I dont see any errors as such running the program. But the UI freezes when the program is run. I am using OSX with with Python 2.7.10

0
Comment actions Permalink

@yeesh When you say "the UI" do you mean PyCharm or the game?

0
Comment actions Permalink

@Paul Everitt,  It was an overlook from my part on the code. I was able to run the Pygame module successfully. Sorry for the false alarm

0
Comment actions Permalink

Same issue here, on OS X and latest PyCharm.

PyGame (installed with conda's pip) GUI is not showing up. To be fair, it showed up only once.

This tutorial is running in the terminal but not in PyCharm.

Any possible solution?

0
Comment actions Permalink

OK, I rebooted my machine, and now it's been working...

If I go to Preferences / Project Interpreter, PyGame is not listed.

Also, if I try to add a new module, nothing shows up...

I have installed Python via Miniconda, with Brew (so it's in /usr/local/miniconda3/bin/).

 

Edit: it's no longer showing the GUI...

Edit2: rebooting PyCharm makes it work, sometimes...

Edit3: figured. The GUI is sometimes hiding behind the editor... so, it's a problem of focus.

Edits4: it's a known problem.

 

Solution: put PyCharm in fullscreen mode, and the GUI will appear on top.

0

Please sign in to leave a comment.