Endless re-indexing

I'm using the latest Webstorm trial version on a Mac with the latest El Capitan beta.

Every time I open a file Webstorm starts indexing, finishes, then starts indexing, finishes, and so on. It never stops indexing like that until I close the file and it causes my dock icon to continually bounce. I haven't found anything searching for this issue.

Can anyone point me in the right direction to solve this?

Thanks,
Ted

7 comments

Please try invalidating caches (File/Invalidate caches, Restart) - does the problem persist?

If yes, please attach your idea.log

2

Interestingly enough, I had closed the app. When I started WebStorm this time to try your suggestion I noticed that it is no longer doing the endless re-indexing. I also performed your suggestion and have been opening a bunch of different files testing it. It seems to be fine now. I'll be sure and post if it happens again and try to give steps to reproduce.

Thanks!

0

I see, thanks for update:)

Some general tips:

- if you are using any build tools (Gulp, Grunt, etc.) that are watching your files and generating stuff when they change, make sure to exclude the build destination directory from project (Mark directory as/Excluded), as constant files re-creation would cause indexes re-building

- make sure that WebStorm caches directory (usually /Users/your_name/Library/Caches/WebStorm11) and files/subfolders in it are not touched by any process except for WebStorm - anti-viral tools, cleanup utilities, etc. If indexes are deleted/changed by any external process, WebStorm attempts to re-build them

0

Elena, I have seen tens of people having getting anoyed by Webstorm re-indexing all the time, especially on macOS. 95% of times this is not caused by Webstorm itself but by super popular pluging ".ignore". Some versions of that plugin do not have that issue but it keeps comming back. First thing to advice to anybody is to disable that plugin. Hope this helps.

2

@Elena Pogorelova, consider moving to an incremental parser, a la: https://www.thestrangeloop.com/2018/tree-sitter---a-new-parsing-system-for-programming-tools.html

So that you don't need to reindex everything all at once.

0

@Rmirek, I'm going to try removing the .ignore plugin

0

Just in case someone is desperately looking for a solution and invalidating cache nor disabling the ignore plugin isnt working for you, make sure your public, node_modules, tmp and log directories are excluded (right click on folder - 'Mark Directory as'). You dont wanna be searching in these files by default anyway.

I am 105% sure I had excluded them before, but I guess the new patch has canceled their exclusion and it took me a while to realize this. Anyway, excluding the public folder did the trick for me.

0

Please sign in to leave a comment.