Have you moved forums????

Answered

My debugging set up is all to **!$@@*. I posted a question and somone kindly gave a comprehensive answer. Was about to put in 30-60 mins to get debugger working properly but damned if I can find the posting anywhere. 

 

Is there another PhpStom forum. I remember it taking about 10 mins to find. This one seems quite straightforward. Anyone any idea where I was.

 

TIA my head is spinning from trying to disentangle a circa 3000 line monster (which I wrote BTW)

Steve

5 comments
Comment actions Permalink
Official comment

Hello,

Yes, we've migrated all the product forums to Zendesk Community Forums (where we are right now). We've implemented a special redirect application which provides post-to-post (aka thread-to-thread) and message-to-message (aka comment-to-comment) redirects for all the forums. That means you should be able to find your old question. Btw isn't it this one?

Thanks!

Dmitry

Comment actions Permalink

Dmitry perfect - thank you. 100/100 for great assistance.

 

Will try and make myself get my head around debugging when I am awake tomorrow. Is there a good IN DEPTH tutorial/primer or anything?? Last time I looked I was 100% confused. I have never used a debugger before but it would be so helpful now.

 

Edit: Looks like the other post has a few pointers. It is midnight here in the Pacific so off to bed. Will read through them in the morning.

0
Comment actions Permalink

You're welcome!

 

I guess you can search some on YouTube, i.e. start with http://www.youtube.com/watch?v=rqDDJfG6ip4

There are plenty of them you can use by searching "phpstorm debug" if you're preferring videos over static guides.

Else there are plenty of official guides: this, this or Tutorials main page if you would like to search from a scratch.

 

Thanks,

Dmitry

0
Comment actions Permalink

EDIT: Sorted JS has to be in external file. Bit of a pain as for dev I like to have everything in one file then move it out but ... 

 

Dmitry slowly getting there but have hit a problem - I cannot set JS breakpoints. I am using jQuery - does PhpStorm support that -m cannot believe it dos not.

 

$(document).ready(function () {
$("[type='checkbox']").on('change', function () {
if ($(this).prop('checked')) {
$(this).prev()
.removeClass('glyphicon-unchecked')
.addClass('glyphicon-check');
}
else {
$(this).prev()
.removeClass('glyphicon-check')
.addClass('glyphicon-unchecked');
}
});

$("input:checked").prev()
.removeClass('glyphicon-unchecked')
.addClass('glyphicon-check')
.parent()
.addClass('active');

Cannot put breakpoint next to any of those.

(I have cross-posted this with Andriy's post as want to get on and not sure if either of you are around now (Friday evening in Europe))

ATB
Steve
0
Comment actions Permalink

Accidental extra post cannot remove

0

Please sign in to leave a comment.