Synchronizing Selective Settings as read-only for a team


I have some Scala formatting settings for IntelliJIDEA 15 Ultimate Edition that I want to share with my team.

The method we used with no success:

  • go to Preferences > Tools > Settings Repository
  • Uncheck "Auto Sync"
  • Add the read-only source our settings repo: git@xxx:yyy/intellij-settings.git

The repository contains scala.xml in the root folder with this content:

  <component name="ScalaSettings">
    <option name="SHOW_TYPE_TOOLTIP_ON_MOUSE_HOVER" value="true" />
    <option name="COMPILE_SERVER_ID" value="c0fffcbc-9ce0-4824-9d96-77e4dd39e9e4" />
    <option name="COMPILE_SERVER_SDK" value="1.8" />
    <option name="COMPILE_SERVER_SHUTDOWN_IDLE" value="false" />
<code_scheme name="XXX Scala Standard">
And ./codestyles/CompanyStandard.xml with the following content: 
    <option name="WRAP_BEFORE_WITH_KEYWORD" value="true" />
    <option name="ALIGN_IN_COLUMNS_CASE_BRANCH" value="true" />
    <option name="ALIGN_COMPOSITE_PATTERN" value="false" />
    <option name="SPACE_AFTER_TYPE_COLON" value="false" />
    <option name="XML_LEGACY_SETTINGS_IMPORTED" value="true" />
  <codeStyleSettings language="Scala">
    <option name="ALIGN_MULTILINE_EXTENDS_LIST" value="true" />
    <option name="CALL_PARAMETERS_WRAP" value="5" />
    <option name="METHOD_PARAMETERS_WRAP" value="5" />
    <option name="EXTENDS_LIST_WRAP" value="1" />
    <option name="FOR_STATEMENT_WRAP" value="2" />
    <option name="IF_BRACE_FORCE" value="3" />
    <option name="FOR_BRACE_FORCE" value="1" />

Am I doing something wrong?


It is fixed in 2017.1 EAP. Please try it.


I've attached screenshots below of everything I have and setup but I don't understand how this is suppose to work. The "scratches" folder is the one I want to add as a read-only repository.


I have the same problem.

I added some configurations, i.e. external tools, Wrapping etc.

Now if I start with a new profile the settings are set correctly (if I added the correct certifcate settings)

This is related to:


Please sign in to leave a comment.