Page requested without authorization

Whenever I open a new link from my client webapp I am getting the following warning from the IDE:

Page 'http://localhost:63343/E…hedulerApp/app/index.html' requested without authorization,
you can copy URL and open it in browser to trust it.

If I continue I get a 404 response from the opened page. I have to go to the address bar and press enter to be able to access it.

Also, if I try running my app without a server, I am getting a CORS error and angularjs doesn't make any request to the web service where data is pulled from.

How can I tackle this issue? Especially the one about opening link, which is pretty annoying.


Please follow the instructions - copy the URL to clipboard and then paste it into browser address bar; this popup is a result of security fixes that prevent unauthorized access to resources. see

Note that this popup only occurs when you run your application outside of the IDE, by opening the URL in browser. If you run/debug it from WebStorm, it's authorized automatically


I am running my application with Shift+F10 and it's being opened in Chrome. This popup only happens when I try opening a link in a new tab. How can I authorize that?


what do you mean by opening link in new tab?  Please can you check if the problem persist in 2016.2 EAP (, with "Allow unsigned requests" option enabled (Settings | Build, Execution, Deployment | Debugger)?


Thank you! That option was the key.


thank you very much Elena Pogorelova


Дай бог тебе здоровья, Леночка !!!


This is happening on PHP storm and I don't have a "debugger" option under (Build, Execution, Deployment).  Any Idea?


it should be there - the corresponding plugin is bundled with PhpStorm and enabled by default. Make sure to check Preferences (of you are on OSX) or Settings (on Linux/Windows) and NOT 'Default settings'


That did it.  Thanks for that.  Default Settings is surprisingly similar.  Maybe a color change or something to signal someone they are in the wrong place?  


Thanks again.


The annoying focus-stealing dialog that pops up should have a link directly to the settings page for "Allow unsigned requests" - instead every time I install the IDE on a new machine I have to google back to this page to figure out how to stop it.


This setting definitely needs to be surfaced or presented in the dialog.  On Mac OS using full-screen, it constantly flips to another screen to display this dialog... twice.  Extremely frustrating.

So glad I found this thread!


I'm having problems with this in the two latest stable PHPStorm #PS-173.3942.32 and  #PS-173.4127.29. In my projects I have setup JavaScript debug and the URL in one of them look like this:


When I choose this in dropdown an press the bug-icon I get this message and not only doesn't it work, the URL copied to clipboard looks like this:


When this is opened the path is wrong so I have to edit in my path before entereing it EVERY TIME. This is painful! How do I fix this?


This shouldn't normally happen on debugging - only on opening the page externally. Anyway, did you try enabling "Allow unsigned requests" (see above)?


The "Allow unsigned requests" helped. I then tried to undo it to understand more and to my surprise it still worked. Keep in mind I have tried restarting and fiddling with just about everything except configurations since it worked with the earlier versions. I guess the config was unconclusive from an earlier version and has become more strict perhaps? I tend to patch ugrade always and I'm using EAP most of the time. Anyway thanks for getting me back to work :)



Запрошенное окно с ссылкой  Страница «http: // localhost: 63342 / w… ist / css /», запрошенная без авторизации,
вы можете скопировать URL-адрес и открыть его в браузере, чтобы доверять ему.


я вставлял этоу ссылку в браузер, открывалась страница с кодом, что мне с этим делать? 


>я вставлял этоу ссылку в браузер, открывалась страница с кодом

 А что вы ожидали увидеть, открывая файл в браузере - разве не код из этого файла?


Please sign in to leave a comment.