Page requested without authorization

Whenever I open a new link from my client webapp I am getting the following warning from the IDE:

Page 'http://localhost:63343/E…hedulerApp/app/index.html' requested without authorization,
you can copy URL and open it in browser to trust it.

If I continue I get a 404 response from the opened page. I have to go to the address bar and press enter to be able to access it.

Also, if I try running my app without a server, I am getting a CORS error and angularjs doesn't make any request to the web service where data is pulled from.

How can I tackle this issue? Especially the one about opening link, which is pretty annoying.

19 comments

what do you mean by opening link in new tab?  Please can you check if the problem persist in 2016.2 EAP (https://confluence.jetbrains.com/display/WI/WebStorm+EAP), with "Allow unsigned requests" option enabled (Settings | Build, Execution, Deployment | Debugger)?

39

The annoying focus-stealing dialog that pops up should have a link directly to the settings page for "Allow unsigned requests" - instead every time I install the IDE on a new machine I have to google back to this page to figure out how to stop it.

2

I am running my application with Shift+F10 and it's being opened in Chrome. This popup only happens when I try opening a link in a new tab. How can I authorize that?

1

Thank you! That option was the key.

1

This setting definitely needs to be surfaced or presented in the dialog.  On Mac OS using full-screen, it constantly flips to another screen to display this dialog... twice.  Extremely frustrating.

So glad I found this thread!

1

This shouldn't normally happen on debugging - only on opening the page externally. Anyway, did you try enabling "Allow unsigned requests" (see above)?

1

>я вставлял этоу ссылку в браузер, открывалась страница с кодом

 А что вы ожидали увидеть, открывая файл css.map в браузере - разве не код из этого файла?

1

thank you very much Elena Pogorelova

0

Дай бог тебе здоровья, Леночка !!!

0

This is happening on PHP storm and I don't have a "debugger" option under (Build, Execution, Deployment).  Any Idea?

0

it should be there - the corresponding plugin is bundled with PhpStorm and enabled by default. Make sure to check Preferences (of you are on OSX) or Settings (on Linux/Windows) and NOT 'Default settings'

0

That did it.  Thanks for that.  Default Settings is surprisingly similar.  Maybe a color change or something to signal someone they are in the wrong place?  

 

Thanks again.

0

I'm having problems with this in the two latest stable PHPStorm #PS-173.3942.32 and  #PS-173.4127.29. In my projects I have setup JavaScript debug and the URL in one of them look like this:

http://localhost:63342/project/dist/index.html#happening/edit/3578

When I choose this in dropdown an press the bug-icon I get this message and not only doesn't it work, the URL copied to clipboard looks like this:

http://localhost:63342/project/dist/index.html?_ijt=euok9jto5klp08c1t1ubtvaf00

When this is opened the path is wrong so I have to edit in my path before entereing it EVERY TIME. This is painful! How do I fix this?

0

The "Allow unsigned requests" helped. I then tried to undo it to understand more and to my surprise it still worked. Keep in mind I have tried restarting and fiddling with just about everything except configurations since it worked with the earlier versions. I guess the config was unconclusive from an earlier version and has become more strict perhaps? I tend to patch ugrade always and I'm using EAP most of the time. Anyway thanks for getting me back to work :)

 

0

Запрошенное окно с ссылкой  Страница «http: // localhost: 63342 / w… ist / css / bootstrap.css.map», запрошенная без авторизации,
вы можете скопировать URL-адрес и открыть его в браузере, чтобы доверять ему.

 

я вставлял этоу ссылку в браузер, открывалась страница с кодом, что мне с этим делать? 

0

Please follow the instructions - copy the URL to clipboard and then paste it into browser address bar; this popup is a result of security fixes that prevent unauthorized access to resources. see http://blog.jetbrains.com/blog/2016/05/11/security-update-for-intellij-based-ides-v2016-1-and-older-versions/

Note that this popup only occurs when you run your application outside of the IDE, by opening the URL in browser. If you run/debug it from WebStorm, it's authorized automatically

-15

Please sign in to leave a comment.