PhpStorm 10 - Font is way too large.

Hello,

I was wondering if anyone else has run into this issue. I just installed PhpStorm, and everything is zoomed in so huge that I can't even use it. For reference, here's a picture of my Netbeans window maximized (monitor resolution at 1600x900):

Now, here's a picture of my PhpStorm window maximized (same monitor, same resolution, same dimensions):

I can't even get to the Okay button in the settings because it expands way past my screen. My resolution is at 1600x900, so there should be plenty of room. The splash screen when it's loading takes up nearly the entire monitor as well.

Don't get me wrong, I like being able to read the font from 100 yards away, but it's not feasible to do any coding with.

Does anyone have any suggestions?

2 comments
Comment actions Permalink
Official comment

Hello,

Do you have any display scaling configured in your OS?

Please check File | Settings | Appearance & Behavior | Appearance > Override default fonts option for all IDE fonts except Editor and File | Settings | Editor | Colors & Fonts | Font for default Editor font. Try to set them to some lower values.

Comment actions Permalink

Thanks Vladimir - I hadn't taken this step because it was "not recommended" but it was the solution.

0

Please sign in to leave a comment.