Disabling autocompletion of code

Hi,

I've navigated all the preferences trying to get rid of a feature I find particularly annoying - pycharm auto-inserting dynamically as I type.

Despite unpicking everything related to code completion that I can find (Preferences / Editor / Code Completion -> Untick everything), I still have the behaviour that if I type:

class MyClass():

def __init__(self):

It ends up autocorrected to the following:

class Bus():

def __init__(selfself):

I frequently find errors with unbalanced brackets too, as a result of the same autocomplete and I wish the whole "feature" would just go away and let me type what I type.

Does anyone know if it's possible to just get rid of the autocomplete functionality please? What tick boxes have I overlooked?

(For the record, I find code completion very useful, e.g. selecting options from a popup, just not when it dynamically modifies what I'm typing while I'm typing!!)

Thanks for any help you can give!

Tom

 

 

 

Please sign in to leave a comment.