Auto-upload doesn't work

Answered

Hi!

I have PHPStorm 10, and auto-upload isn't working. I configured the Remote Host, and it shows the files on the host in the interface, so I have the password right. I have "Auto-Upload" checked in Tools->Deployment menu, and it's set to "Always". I have the Remote Host set to "Use as Default" in the Deployment settings.

I can copy the file in the Project browser and paste to the Remote Host window, and it uploads to the right place. It just won't do it when I save changes automatically.

7 comments
Comment actions Permalink

Hi Ethan,

 

What message do you get when you click Tools > Deployment > Upload to <your_remote_hostname> ?

Do you get any message in a File Transfer tab (View > Tool Windows > File transfer) when you change file and hit Ctrl+S? 

 

Thanks!

0
Comment actions Permalink

Upload isn't an available option.

No messages in the File Transfer window when I hit -S.

0
Comment actions Permalink

Looks like there's an issue with configuration. Please check > Configuration... > Mappings tab (and attach a screenshot if everything looks Ok).

 

Thanks!

0
Comment actions Permalink

Ah! It was "Deployment Path On Server" was empty. I put in "/" and it works now. Thanks so much for your help.

0
Comment actions Permalink

You're welcome! Glad this is working now :)

0
Comment actions Permalink

Following up on Ethan Larson, I put my target remote path into "Deployment path on server" (instead of just a "/"). So then the option to Upload to Server reappeared again. But then I ran into the error "No files or folders found to process" which I have not yet found a solution for.

0
Comment actions Permalink

Do you have this error after a commit? What IDE version are you running?

0

Please sign in to leave a comment.